Does anyone know if there is a plan to have this issue verified and fixed so I may upgrade Mantis.  I don't want to do so until this required field issue is resolved as part of 1.2.x -
 
http://www.mantisbt.org/bugs/view.php?id=11684
 
I have seen multiple notes about fixes and patches - but it doesn't seem that anyone is satisfied with the solution yet.   I just wanted to be sure.
 
KM