#39 does not handle MIME attachments properly in VM

closed-postponed
nobody
None
5
2007-12-10
2005-07-15
Anonymous
No

mailcrypt 3.5.8, vm 7.19, gpg

setting

(defun my-mail-send-hook ()
(vm-mime-encode-composition)
(mc-sign-message))

(add-hook 'vm-mail-send-hook 'my-mail-send-hook)

makes signing outgoing messages automatic. The message
is, however, broken if there is an attachment included.

The vm complains:

MIME part missing header/body separator line

the message looks as follows:

- mark of BEGIN PGP SIGNED MESSAGE
- Hash: SHA1

- "- --" followed by the MIME separator
- the message

- "- --" followed by the MIME separator
- the attachment

- "- --" followed by the MIME separator
- the signature block

- "--" followed by the MIME separator

i.e. the signature related stuff is in the beginning
before the MIME separator, but the last MIME separator
is outside the signature stuff

kex@iki.fi

Discussion

  • nega

    nega - 2007-11-26

    Logged In: YES
    user_id=346358
    Originator: NO

    This is a long-standing problem w/ VM + mailcrypt

     
  • nega

    nega - 2007-11-26
    • status: open --> pending-postponed
     
  • SourceForge Robot

    • status: pending-postponed --> closed-postponed
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks