T|2 nothing works

quillim
2005-04-08
2013-03-26
  • quillim

    quillim - 2005-04-08

    I can't get anything to work with my T|2

    Always some kind of error. Is there a specific version I should use? It says I am out of memory a few times.

    Thanks

     
    • karol

      karol - 2005-04-08

      The same with my T|2

       
    • Nicholas Hardy

      Nicholas Hardy - 2005-04-09

      Please try again with the new release: 0.3.0

       
      • karol

        karol - 2005-04-09

        I tried wit new version 0.3.0.

        When trying playing mp3 file:
        * i can get info about file, it's name, type: MusicFile, and size 4MB
        * when i press play for a few seconds nothing is happend, then I got error "Uknown System Error. (1) [main/sound.c:235], next error is "main/sound.c, Line:265, INTERNAL ERROR" and I can only reset my Palm,

        * playing movie from
        http://hi.errai.net/~nicholas/magiclantern/sample.zip:
        I got error "Unknown System Error.(1)  [tml_xvid.c:133],
        after pressing OK I got green screen

        I hope this would help in preparing version that works with T|2

         
        • Nicholas Hardy

          Nicholas Hardy - 2005-04-11

          Mp3 error:

          Ok, this error seems to referring to an error returned from the operating system when I try to initialise a sound stream.  The most likely cause I can think of would be an unsupported sample rate - I think some of the TT1/TT2's support a limited set of the standard rates.  Make sure your mp3 file uses something like 22.05 or 44.1 khz.

          Avi error:

          I'm not certain what's causing this error, but I've just fixed a nasty bug in that region that was causing various random problems.  Might be fixed in the next release.

          Alternatively, all sort of problems can be caused by low memory.  Please try turning the video quality to minimum in configuration and see if that helps.

          Thanks for your help in debugging these problems.

           
    • Ludovic Drolez

      Ludovic Drolez - 2005-04-11

      With my T|1 and TML 0.3.0 I got similar problems.

      But with a 44100Hz .ogg file, nothing happens (no errors, no reset, no freeze).
      In avi mode, playing the 160x120 ST sample (with the audio channel removed) is ok with video quality set to '16' but, if I set it to '4', I get a reset after 0.5 seconds. Strange... with TML pre6, I could only play the avi with the lowest quality setting (UDMH did not help).

       
      • Nicholas Hardy

        Nicholas Hardy - 2005-04-12

        I don't know what's happening with sound.  Could you confirm that you can play audio files in other software?  Preferably with open source players and and with a file that's also failing on TML.

        I think the reason that the lowest quality setting no longer works is that for TML 0.3.0 I upgraded the code to use xvid 1.1-beta1, instead of 1.0.3.  This version seems less tolerant of changes to edge_size.  I've seen this problem as well, maybe we should remove the lowest setting in the next release since it obviously doesn't work anymore.

         
        • Ludovic Drolez

          Ludovic Drolez - 2005-04-12

          Yes, I can play those files with aeroplayer which uses the same lib as TML (for .ogg files).
          Also, you might be interested in PsyTexx source code: http://www.warmplace.ru/soft/psytexx/index.shtml. This GPLed MOD player works perfectly on my TT1.

           
          • Ludovic Drolez

            Ludovic Drolez - 2005-04-19

            I've also tried TCPMP which is distributed under the Gnu GPL. Perfect on my TT1. I just finished to watch a 2h movie in my bed !

            http://corecodec.org/projects/tcpmp/

             
    • Nicholas Hardy

      Nicholas Hardy - 2005-04-23

      Anyone having these problems with a TT1/TT2, could you please test the following version.

      http://hi.errai.net/~nicholas/magiclantern/TML_TungstenBugTest.zip

      This contains some unreleased changes, but more importantly contains some a few small tweaks and tests that I hope may provide some information on this problem.  This version may however be broken for other purposes.

      Could you please try playing some MP3 files with this version and let me know what happens.  There should be an alert that appears and shows something like '11025 18 0 16 1 0', let me know what you get on a failing MP3 file.

      I'm crossing my fingers that I'll get a useful result, cause otherwise I have no idea what's wrong (I've had a glance at the source of some other players and don't see them doing anything significantly different).

       
    • Siege

      Siege - 2007-05-22

      Okay, I'm actually using a Zire 31, with version 0.30, but I got the same error you described:

      {"Uknown System Error. (1) [main/sound.c:235], next error is "main/sound.c, Line:265, INTERNAL ERROR" and I can only reset my Palm"}

      I had a file with audio encoded in Wavepack, but then I reencoded it into Waveform using MediaCoder, selecting the "raw PCM file" option, and it worked after that... sort of. The file seems to be too big to play! (see my own post)

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks