Hi list,

I am trying to install madwifi 0.9.4 and I received the next error:

[root@localhost madwifi-0.9.4]# make
Checking requirements... ok.
Checking kernel configuration... ok.
make -C /lib/modules/2.6.27.25-170.2.72.fc10.i686/build SUBDIRS=/home/Test/madwifi-0.9.4 modules
make[1]: Entering directory `/usr/src/kernels/2.6.27.25-170.2.72.fc10.i686'
  CC [M]  /home/Test/madwifi-0.9.4/ath/if_ath.o
  CC [M]  /home/Test/madwifi-0.9.4/ath/if_ath_pci.o
  LD [M]  /home/Test/madwifi-0.9.4/ath/ath_pci.o
  CC [M]  /home/Test/madwifi-0.9.4/ath_hal/ah_os.o
  HOSTCC  /home/Test/madwifi-0.9.4/ath_hal/uudecode
  UUDECODE /home/Test/madwifi-0.9.4/ath_hal/i386-elf.hal.o
  LD [M]  /home/Test/madwifi-0.9.4/ath_hal/ath_hal.o
  CC [M]  /home/Test/madwifi-0.9.4/ath_rate/amrr/amrr.o
  LD [M]  /home/Test/madwifi-0.9.4/ath_rate/amrr/ath_rate_amrr.o
  CC [M]  /home/Test/madwifi-0.9.4/ath_rate/minstrel/minstrel.o
  LD [M]  /home/Test/madwifi-0.9.4/ath_rate/minstrel/ath_rate_minstrel.o
  CC [M]  /home/Test/madwifi-0.9.4/ath_rate/onoe/onoe.o
  LD [M]  /home/Test/madwifi-0.9.4/ath_rate/onoe/ath_rate_onoe.o
  CC [M]  /home/Test/madwifi-0.9.4/ath_rate/sample/sample.o
  LD [M]  /home/Test/madwifi-0.9.4/ath_rate/sample/ath_rate_sample.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/if_media.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/ieee80211.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/ieee80211_beacon.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/ieee80211_crypto.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/ieee80211_crypto_none.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/ieee80211_input.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/ieee80211_node.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/ieee80211_output.o
  CC [M]  /home/Test/madwifi-0.9.4/net80211/ieee80211_power.o
/home/Test/madwifi-0.9.4/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
/home/Test/madwifi-0.9.4/net80211/ieee80211_power.c:240: error: implicit declaration of function '__skb_append'
make[3]: *** [/home/Test/madwifi-0.9.4/net80211/ieee80211_power.o] Error 1
make[2]: *** [/home/Test/madwifi-0.9.4/net80211] Error 2
make[1]: *** [_module_/home/Test/madwifi-0.9.4] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.27.25-170.2.72.fc10.i686'
make: *** [modules] Error 2
[root@localhost madwifi-0.9.4]#

..... I read some web pages, and I found that the solution is to use a recent madwifi version. I download a recent version from Snapshots, I also download madwifi-ng-0.9.4 and test them, and both works very well.

But, my question is What madwifi files were modified in order to solve this problem ?, because I would like to modified those codes and test them for myself.

I hope your answers,

Thanks,

Hector.