I looked through the tickets again, and someone already have it:

Any answers to fix this ?

I'll keep looking

On 2/23/06, Daniel Wu <> wrote:
I did some more testing, and looks like it broke right at rev 1409 and 1410.
Revision 1408 works fine (i.e.e associates good with the AP)
The other revisions do not.

On 2/23/06, Daniel Wu <> wrote:
Hey guys,

I was wondering if anyone else had a problem with station mode of the madwifi-ng code in r1454.
I tried to connect to a commercial AP, but that didn't work.

I can scan for the APs but can not ping the AP or beyond. 
On the STA, the iwconfig command shows AP: 00:00:00:00:00:00
Even when I force it to a certain AP, it still doesn't work.
(Note: I set the iwpriv mode to 11b, channel 1, essid to the correct one)

The "wlanconfig ath0 list" shows me the AP i'm trying to connect to, but I can't get any data over.

Running ethereal (on a different laptop) doesn't show any packets/frames from the STA.

I have no problems using r1405 though, so I'm going to take a look and see what's been changed inbetween.
Anybody else run into this problem ?