Hi Pavel,

Firewall was off. So that doesnt seem to be the issue..
Do you think, I should try an earlier version of madwifi in combination with an older kernel? 

Thanks
Vivek


On Tue, Sep 27, 2011 at 3:47 PM, Vivek Ramamoorthy <kev.moorthy@gmail.com> wrote:
Hi Pavel,

thanks for the inputs let me try checking the firewall settings.
The madwifi version I am using is svn r4165 (branch madwifi-0.9.4)

Attaching the dmesg, which I had missed out in earlier email.

Thanks
Vivek


On Tue, Sep 27, 2011 at 1:11 PM, Pavel Roskin <proski@gnu.org> wrote:
On Tue, 27 Sep 2011 11:34:53 -0700
Vivek Ramamoorthy <kev.moorthy@gmail.com> wrote:

> Hi All,
>
> I have been trying to use a DLINK DWL-AG530 PCI card along with
> Madwifi to configure the chip in AP mode. Although the client
> associates fine, I am unable to ping ath0 interface.
> I have statically assigned IP to client since I dont have a DHCP
> server running.
>
> So here are the steps I have followed till now:
>
> 1) Downloaded source from http://madwifi-project.org/ and installed
> the same on my linux machine. Here are details of my linux version:
>
> [root@localhost ~]# uname -a
> Linux localhost.localdomain 2.6.27.25-78.2.56.fc9.i686 #1 SMP Thu Jun
> 18 12:47:50 EDT 2009 i686 i686 i386 GNU/Linux

You forgot the version of madwifi.  It it's a snapshot, please specify
whether it's the trunk of the 0.9.4 branch, and what is the date or the
revision of the snapshot.

> 3) In /etc/modprobe.d/madwifi
>
> alias wlan0 ath_pci
> blacklist ath5k
> options ath_pci autocreate=ap
>
> 4) Since I read in forums that DWL-AG530 comes with a broken country
> code, I changed the regdomain to 0x0 (also tried with 0x16)
> 5) modprobe ath_pci countrycode=840
> 6) wlanconfig ath0 destroy
> 7) wlanconfig ath0 create wlandev wifi0 wlanmode ap

You can use the "autocreate=ap" parameter to avoid the need to recreate
ath0.

> 8) iwpriv ath0 authmode 1   (open mode)

I don't think you need to tweak private parameters for basic
functionality.

> 9) iwconfig ath0 essid "test_wlan"
> 10) ifconfig ath0 10.1.1.10 netmask 255.255.255.0
> 11) ifconfig ath0 up
>
> *An issue I see, is that everytime I try to set the channel using
> iwconfig ath0 channel 6 (or whatever) the kernel panics and the
> system goes to hang state, so I leave it at default*

I guess if might be the issue that prevents the release of the
version 0.9.4.1:
https://madwifi-project.org/ticket/1903

The workaround it to set the channel while the interface is down.

> I have a windows 7 client, on which i configure a static IP of
> 10.1.1.12 and connect to wlan "test_wlan". The client associates, and
> also I was able to sniff the assoc rsp, and ack packets from the air
> which had a "Success" status.
>
> However, when I ping 10.1.1.10 (ath0), no response. I get a Dest
> Unreachable from 10.1.1.12. So I added arp entry for 10.1.1.10
> manually on my client. When I do that the ICMP request times out, and
> I do see the ICMP requests in the air.
>
> I have been trying to figure out if the driver is dropping these
> packets due to some configuration thats wrong? Do let me know if
> anyone has faced similar issues.

I suggest that you check firewall settings on Fedora (iptables).  Try
turning it off.

> i have tried using bridges between ath0 and eth0 interface, Even that
> hasnt worked.
>
> Attaching the outputs of ifconfig, iwconfig and dmesg (No errors i
> saw in dmesg) along.
>
> Also, if anyone has used any of the currently available atheros
> chipsets along with Madwifi successfully to set up an AP (Master
> mode), would be great if you could provide me the Chipsets model
> number, and Madwifi version.. I am fine with any Atheros based
> Chipset that is available in the market, as long as I can use it with
> madwifi to setup in AP mode. Just wondering if the DWL-AG530 may be
> having issues in AP mode, since it works just fine as a wireless
> client.

As far as I know, the only chipsets that are supported by MadWifi but
don't work in AP mode are AR5210 and possibly AR5211.  Both are very
old and don't even support 802.11g.

--
Regards,
Pavel Roskin