After I run 

   wlanconfig ath0 create wlandev wifi0 

, I can create ath0 successfully. According to the posts on the internet, I should be able to find ath0 and its parameters under the path /proc/dev. However, I can only find ath and wifi0 under /proc/dev. What I am expecting is the debug parameter under ath0. Does anyone know how to make the driver create that parameter?

Also, when I run athdebug, it always complains that 

athdebug: sysctl-get(dev.ath0.debug): No such file or directory

I think these two issues may be caused by the same thing. Can anyone shed me some light on how to solve the issue?

madwifi info:

ath_hal: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
ath_hal: 2009-05-08 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, REGOPS_FUNC, XR)
ath_pci: trunk
wlan: trunk
wlan: mac acl policy registered
ath_rate_sample: 1.2 (trunk)
PCI: enabling device 0000:00:01.0 (0340 -> 0342)
Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_pci: wifi0: Atheros 5413: mem=0x48000000, irq=28