I've upgraded to OpenSuse 11.1 and started having problems with my TP-Link card (identified as Atheros AR2414 chip found (MAC 7.9, PHY 2112A 4.5, Radio 5.6)).

First, It've tried to use ath5k. The driver does not hang, but gives very low throughput and packet looses.
Next I've installed madwifi 0.9.4 from Opensuse 11.1 repository at madwifi site. It've given me good throughput, but my notebook've started to hang (with blinking Caps Lock/Scroll Lock - so it look like kernel trap?)
OK, I did download trunk from http://svn.madwifi-project.org/madwifi/trunk/ (rev 3913).... and got ath5k throughput and packet looses.
Next thing I've tried is to back my kernel to 11.0 one and use 0.9.4 - this combination works OK. No hangs, good throughput.
Thunk on old kernel also gives problems.
So, I have two problems now that I can't handle:
1) 0.9.4 release hangs on 2.6.27 (may be I should've built it from scratch?)
2) MadWifi Trunk / ath5k works slowly (rates are jumping from 1Mb to 34Mb, a lot of packet lost).
The one thing that is strange for me is that trunk dmesg output is much different from 0.9.4 - so that I could think I am building ath5k, but SVN url seems to be correct and I can see 0.9.4 in tags nearby.