Hey every1

Just a quick q.  -  how do i get x to vsync properly ? whenever i drag a window the refresh is badly out of sync - really ugly  jaggies appear on window edges .. how would i have to alter this in order to have vsync on both the panel and the external monitor ?  heres my xorg (the important stuff pertaining to the video):


Section "Modes"
    Identifier     "Modes[0]"
EndSection

Section "Monitor"
    Identifier   "Builtin"
    VendorName   "Apple"
    ModelName    "BuiltinPanel"
    HorizSync    30.0 - 90.0
    VertRefresh  57.0 - 84.0
    Gamma        1.25
    Modeline "1440x900"   96.31  1440 1504 1536 1760  900 903 906 912 +hsync +vsync
    Option        "CalcAlgorithm" "CheckDesktopGeometry"
EndSection

Section "Device"

#  Device       "auto-dev"
    Option        "FSAAScale" "2"
    #Option        "USeInternalAgpGart" "yes"
    Option        "AccelMethod" "ShadowFB"
    Option        "Centermode" "off"
    Option      "VideoOverlay" "on"
    Option        "RenderAccel" "true"
    Option        "Capabilities" "0x00000800"
    BusID       "PCI:1:0:0"
    Identifier  "radeon"
    Driver      "fglrx"
    VendorName  "ATI"
    BoardName   "ATI Radeon Mobility X1600"
    Option        "OpenGLOverlay" "off"
    #Option        "VideoOverlay" "off"
    Option        "XAANoOffscreenPixmaps" "on"
    Option        "TexturedVideo" "off"
    Option        "Textured2D" "on"
    Option        "UseFastTLS" "1"
    Option        "BackingStore" "on"
    Option        "FSAAEnable" "on"
    #Option        "DesktopSetup" "single"
    Option        "EnableMonitor" "lvds"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"

  #Device       "auto-dev"
  # 32 is an illegal value
    Identifier "default"
    Device     "radeon"
    Monitor    "Builtin"
    DefaultDepth     24
    SubSection "Display"
        Depth     24
        Modes    "900x1440"
    EndSubSection
EndSection

Section "DRI"
    Group        0
    Mode         0666
EndSection

Section "Extensions"
    Option        "Composite" "Enable"
    Option        "RENDER" "Enable"
    Option        "DAMAGE" "Enable"
EndSection


Thanx for any suggestions ..