Problems connecting with MacSSH

Help
2001-07-10
2001-08-04
  • Ryan Castleberry

    Subject: Problems connecting with MacSSH

    Setup:
    I am attempting to connect a Mac G4 cube OS 9.1 client to a RedHat 6.1 running OpenSSH 2.9. Both SSH1 and SSH2 are enabled on our server. We use ssh with RSA based authentication for remote access with Win32 computers via SSH1 with no problems. I am interested in MacSSH as it implements RSA and port forwarding.

    First problem:
    Authorization failed when using ssh key generated from MacSSH.
    I "Initialize SSH...", creating an identity and identity.pub file. I then "Export public key..." - identity.ssh2.pub.
    identity.ssh2.pub and identity.pub contents do not look the same. I've tried both the contents of identity.ssh2.pub and identity.pub in authorized_keys on the server, and I get:
    User authentication failed.
    lsh: Public key userauth failed.
    Connection died.
    I am able to get a successful authorization by generating the idenity and identity.pub on another machine and using those instead, but...

    Second problem:
    The terminal window comes up, but is blank
    This is what I get from the Log Window:

    Garbage collecting while busy...
    Objects alive: 95, garbage collected: 39
    Garbage collecting while busy...
    Objects alive: 180, garbage collected: 270
    Initiating handshake with myserver.com
    do_arcfour_random_slow: Initalizing randomness pool.
    Client version: SSH-2.0-lsh_1.2 lsh - a free ssh2 on MacOS9
    Server version: SSH-1.99-OpenSSH_2.9p2
    Selected keyexchange algorithm: diffie-hellman-group1-sha1
      with hostkey algorithm:       ssh-rsa
    Selected bulk algorithms: (client to server, server to client)
      Encryption:             (3des-cbc, 3des-cbc)
      Message authentication: (hmac-sha1, hmac-sha1)
      Compression:            (zlib, zlib)
    SPKI host authorization successful!
    lsh: Invalid ur unimplemented advanced-style expression
    read_buffered: fd died, 532 buffered bytes discarded

    It looks to me that some kind of session is happening as I see ssh disconnects in /var/log/messages from my Mac IP.

    Any help would be greatly appreciated.

    Ryan Castleberry
    ryan@platte.com

     
    • Ryan Castleberry

      Solution:
      It seems that my problem was just with the keys.
      lsh and OpenSSH have two different formats for keys.

      This is what I had to do:
      Once I had the identity.ssh2.pub on my redhat server, I ran ssh-keygen to translate the key as follows:
      # ssh-keygen -i -f identity.ssh2.pub >> authorized_keys2
      -i import and -f file...

      Everything worked ok from there...
      Ryan Castleberry

       
      • Hans Lohmander

        Hans Lohmander - 2001-08-04

        Yes,
        but the line "sshd[22556]: userauth_pubkey: unsupported public key algorithm: spki-sign-dss" still remain in /var/log/messages.
        Is there a way to avoid this?

        btw. the privs must be user rw only for this to work.
        -rw------- 1 xxx xxx 589 Aug  4 16:31 authorized_keys2

        /Hans

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks