Port Forwarding Issues,

2001-06-12
2001-06-14
  • Chip Mefford

    Chip Mefford - 2001-06-12

    Okay,

    I've tried X, Y, and then Z, and I can't get anywhere
    with port forwarding.

    It seems pretty straightforward, what I am trying
    to do, and near as I can tell, from the docs, this
    SHOULD be simple.

    In linux, to do what I am trying to do,

    I simply use this set of arguments

    "ssh -L portnumber:citrix-server.domain:portnumber ssh-server"

    Then I connect my application, in this case, ICA client
    for Citrix to Localhost and away I go.

    Trying to do this with MacSSH, and I cannot get it
    to work, I've tried adding

    "-L portnumber:citrix-server.domain:portnumber"
    in the command window in the Security Settings tab, and I have tried setting "Remote TCP port forward"
    Local port portnumber Remote host citrix-server.domain Remote port portnumber in the SSH2 tab and connecting
    to the ssh server. In both cases, the mac connects to the
    ssh server just fine, but no port is being forwarded from
    the citrix server, I can't find the port on the mac, and
    netstat on the citrix server shows no connection.

    HELP!!!

     
    • Chip Mefford

      Chip Mefford - 2001-06-13

      Okay, I finally got it to connect.

      However, the only way i could connect was to
      select "allow guests".

      This kinda defeats the purpose, as anyone scanning
      ports, or anticipating ports, could connect, as if
      I had the server I was connecting to live on the
      internet.

       
    • Jean-Pierre Stierlin

      not a bug: you need to use 127.0.0.1 instead of localhost.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks