Antialiasing always fails! :¬( (v0.12)

Help
Raptor007
2006-02-24
2013-04-17
  • Raptor007

    Raptor007 - 2006-02-24

    I really want to get antialiasing working!  But I get this no matter what game I try with (Carmageddon, Unreal, etc):

    MacGLide has encountered an unrecoverable error and cannot continue.
    Excuse:
    AGL-Error: invalid enumeration

    I tried setting FullSceneAntiAliasing to 1, 2, and 4 but no luck.  It only works at 0.  I'm running Mac OS X 10.4.5 with classic (my G5 won't boot OS 9).  I have a GeForce 6800 Ultra.

    By the way, I really like the resolution-force option.  Carmageddon looks great now!  :¬)  I'm sad that Unreal / UT are so slow though, because I was so excited to play Unreal and play UT with the music (the OS X version has no music).

     
    • Jens-Olaf Hemprich

      Hi ya,

      you're out-of-luck, FSAAA works with ATI Radeon cards only,  because NVidia doesn't provide the trick I have to use to get it working on ATI Radeon cards.

      It's possible to do antialiasing by using the OpenGL Accum buffer, much like in this example here:

      http://www.cs.uiuc.edu/class/sp06/cs419/accum/accum.html

      But the method used doesn't really look like a speed killer...

      Also MacGLide would have to cache all the vertex data, along with texture images nad framebuffer data, because doing AntiAliasing with the Accum buffer requires to render the whole frame multiple times (not just each geometry one after another).

      Regarding Unreal performance: I'm a little bit surprised it's running slow on a G5? It's not bad on my 450Mhz Cube. What is your current frame rate?

      Regards, Jens

       
    • Raptor007

      Raptor007 - 2006-03-18

      Well, timedemo on Unreal 1 gives me an average of 33, but a low of 7.

      Fog slows me down a little.
      Reflections slow me down a little more.
      Lighting slows things down quite a bit.
      Dynamic lights KILL the framerate.  This ruins combat, of course.  :)

      I know how to disable dynamic lights in UT, but I haven't yet found out how in Unreal.

      I did find a method of diabling ALL lighting in Unreal, which gives me smooth-as-butter framerates even with fog and reflections on.  But the game looks uuuuuugly.  :)

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks