problems with MacCVSPro, OS X, and netatalk

Tym Altman
  • Tym Altman

    Tym Altman - 2002-11-08

    I also posted this to the netatalk forum, but I'm posting it here since it may have something to do with MacCVSPro as well.

    We have a debian linux network at work. We have our main file server on one machine where our home directories are, and individual boxes where we mount the home directories using NFS/NIS.
    We've been using netatalk (1.4b2+asun2.1.3-6) on the fileserver for some time, and with OS 9 it has always worked flawlessly. Since I've updated to OS X (currently 10.2.1) I've been having some pretty major problems:
    1) Checking out with MacCVS Pro 2.7b3 fails on many files with either -43 or -50 errors.
    2) Saving files (form ProjectBuilder IDE) sometimes fails, and a file with a name such as data3523.007 will be placed in the same directory. Sometimes the file being saved will disappear, or the file will be empty after saving.

    I've reported a bug to apple, but so far they have not addressed it. Someone on one of apple's discussion groups said that I should try version 1.55. I've installed it on my local machine. He told me to use --with-did=cnid.

    Now I'm getting the following problems in addition to the above which exist when I mount the main fileserver with the 1.4 version of netatalk:

    1) Copying files to my home directory will result in a -36 error. Deleting files fails with "file busy" errors.
    2) If I copy/delete to a directory other than the home (which is NFS mounted) it works fine, but I still have the -43 and -50 problems when checking out using MacCVS Pro.

    I'd really appreciate some help, as I'd love to be able to use netatalk and MacCVS Pro the way I've been used to on OS 9, but I'd like to work in OS X.


    • Tym Altman

      Tym Altman - 2003-03-08

      Just to follow up. I'm starting to think that some/all of the problems I have with netatalk and OS X are to do with the way files are checked out onto the debian file server using the MacCVSPro client. I've tried to reproduce my problems using plain source code files copied and saved hundreds of times to various directories on the server, and I can't get it reproduced.

      But resaving/checking out files in my MacCVSPro source directory on the server, exhibits the problems several times a day.

      Is anyone else keeping their source on a linux server, and using MacCVSPro as the client? Or is everyone checking out their code onto their OS X machine?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks