problem with mac4lin gtk metacity

Marcus
2007-12-20
2012-10-08
  • Marcus
    Marcus
    2007-12-20

    Hi, mac4lin is a great job and i'm very soddisfate to use this on my ubuntu gutsy.
    I find somes bug that report now:
    -maximize windows of Inkscape and EasyTag don't work fine, and i can't resize the high of window.
    -icon of gnome-terminal is very big and you don't resize it.
    -when i run some application from terminal i see this warning message "Invalid borders specified for theme pixmap:
    /home/user/.themes/Mac4Lin_GTK_Graphite_v0.4/gtk-2.0/Buttons/button-default.png,
    borders don't fit within the image

    I hope that this message can help you to improve your beautiful project.
    Thanks for all
    Bye

     
    • Thats really strange, if vim can identify the return carriage then whats the problem with gedit??! Is gedit incapable of generating a clean text file? I gotta look into this!

       
    • I haf mailed you regarding this. Kindly go thru the email and provide more details.

       
    • Marcus
      Marcus
      2007-12-21

      Thanks for reply. I sent you email with screenshots.
      Bye

       
    • Marcus
      Marcus
      2007-12-22

      Hi,
      i solved the problems! The problem was caused by bad resolution of my video card and monitor (1024x768), i change it to native resolution (1280x1024) and all work fine, inkascpe, easytag.. Also the issue of big terminal icon is solved, i just select the icon on /home/<username>/.icons/<Mac4Lin icon theme>/scalable/apps and now has the correct size.
      Thank you for all!

      Marcus

       
    • I receive this error when running GUI appliations from terminal, at native resolution.
      Not a big deal, but likely something to look into for v0.5 ?

       
    • What error?

       
    • "Invalid borders specified for theme pixmap:
      /home/user/.themes/Mac4Lin_GTK_Graphite_v0.4/gtk-2.0/Buttons/button-default.png,
      borders don't fit within the image"

       
      • Hi, jumping in ...

        I edited ~/.themes/Mac4Lin_GTK_v0.4/gtk-2.0/gtkrc with vim to remove all the ^M (windows return char) and the problem disappeared. Mayeb a dos2unix would have done the trick...

        HTH