Getting Ali Webcam working under Intrepid

Anton Post
2009-04-28
2013-03-08
  • Anton Post

    Anton Post - 2009-04-28

    Hi

    I'm not by any stretch a Linux expert, although I've been running it for a
    couple of years on my last two laptops. I currently have an Asus Z92 style
    laptop, running an AMD Turion 64, which may be relevant.

    I have been trying to set up my in-built webcam, but unfortunately am finding
    the instructions a little hard to apply in my case.

    Running "lsusb" includes the following line:
    Bus 004 Device 004: ID 0402:5603 ALi Corp. USB 2.0 Q-tec Webcam 300

    Running "uname -a":
    Linux Pippin 2.6.27-11-generic #1 SMP Wed Apr 1 20:53:41 UTC 2009 x86_64 GNU/
    Linux

    I downloaded the 2.6.27 version:
    "Intrepid or Kernel >= 2.6.27
    The latest driver only works with kernel version >= 2.6.27 (Intrepid) is here:
    http://linuxtv.org/hg/~eandren/gspca-m5602/archive/tip.tar.gz"

    I compiled it, and apart from 5 or 6 warnings it seems to have completed ok. I
    then ran "sudo make install" and that seemed to go ok too. "sudo modprobe
    gspca_m5602" returned no output so I assume that was ok, although I'd like to
    be certain this is the one for my 5603 webcam?

    Looking in Package Manager, I have libv4l-0 (0.5.7-1) installed (after this
    didn't work, I was looking at some other help sites and installed lib32v4l-0
    (0.5.7-1) as well - no difference).

    Problem is Ekiga and Skype still say "No video device".

    I tried "export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so" and running "skype"
    after that from the terminal and get the message
    "ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be
    preloaded: ignored."

    This was the stage I installed lib32v4l-0, and tried
    "export LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so" instead.
    Running "skype" after this doesn't give the error.

    Conversely, running "ekiga" works for the first setting and not for the second,
    from which I surmise that I am running 32-bit Skype and 64-bit Ekiga?

    On Ekiga I can choose V4L or V4L2 - no difference.

    Have I missed something, or is this a hardware difference? I have had the
    webcam working under Windows.

    Many thanks,
    Anton

     
    • cmavr8

      cmavr8 - 2009-04-29

      So did it finally work with either skype or ekiga or not? I didn't quite understant.

       
    • Anton Post

      Anton Post - 2009-05-04

      Sorry, that "works" was a red herring - I just meant that I did or didn't get the ERROR.

      In summary - I have had NO joy in my webcam detecting under ANY software, apart from at the USB level.

      Do you have any tips?

      Thanks,
      Anton

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks