livecam: ./configure failed

  • gerard ROBIN

    gerard ROBIN - 2008-11-18


    on my laptop acer aspire 5102 wlmi I installed the driver m560x successfully.
    But when I installed livecam  ./configure failed:

    checking for jpeglib.h... yes
    checking ffmpeg/avcodec.h usability... no
    checking ffmpeg/avcodec.h presence... no
    checking for ffmpeg/avcodec.h... no
    configure: error: ffmpeg-devel is required to build LiveCam

    I use debian unstable (kernel 2.6.26) after I installed the package libavcodec-dev, the command:
    apt-file search ffmpeg/avcodec.h
    libavcodec-dev: /usr/include/ffmpeg/avcodec.h
    libavcodeccvs-dev: /usr/include/ffmpeg/avcodec.h
    libmyth-dev: /usr/include/mythtv/ffmpeg/avcodec.h

    But ./configure gives always the same result.

    Can someone explain to me what I am missing.

    Thanks in advance.

    • gerard ROBIN

      gerard ROBIN - 2008-11-21

      problem solved:
      in debian avcodec.h  is in /usr/include/ffmpeg/libavcodec/avcodec.h
      I copied the file avcodec.h in /usr/include/ffmpeg/ and ./configure worked fine.
      configure needs qt-mt and I installed the package  libqt3-mt-dev.
      Finally make created the file livecam which works like charme.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks