Error with make install

Help
2005-10-14
2013-01-02
  • Roland Bengtsson

    I have trying to install lxr from the instructions on http://www.iol.ie/~locka/mozilla/lxr.htm
    But I got error when doing make install. I have also tried make install from a Knoppix Live CD with exactly the same error message.

    Is there any step by step installation guide?

    -------------makefile--------------

    # Makefile for installation and configuration of LXR

    # The location of your perl5 binary
    PERLBIN=/usr/bin/perl
    # LXR will be installed here,
    INSTALLPREFIX=/mnt/sda1/lxrbase

    # End of configuration parameters
    CGISCRIPTS=find ident search diff source
    PERLMODULES=SimpleParse.pm Common.pm Config.pm

    config: $(CGISCRIPTS) $(PERLMODULES) genxref

    $(CGISCRIPTS) genxref: %: %.in
    sed s%@perlbin@%$(PERLBIN)% < $< > $@

    install: config genxref
    install --directory $(INSTALLPREFIX)/http
    install --directory $(INSTALLPREFIX)/http/lib
    install --directory $(INSTALLPREFIX)/http/lib/LXR
    install --directory $(INSTALLPREFIX)/bin
    install --directory $(INSTALLPREFIX)/source
    install --mode 755 $(CGISCRIPTS) $(INSTALLPREFIX)/http/
    install --mode 750 genxref $(INSTALLPREFIX)/bin/
    install --mode 755 Common.pm Config.pm $(INSTALLPREFIX)/http/lib/LXR
    install --mode 755 SimpleParse.pm $(INSTALLPREFIX)/http/lib/
    install --mode 644 http/* $(INSTALLPREFIX)/http/

    clean:
    rm -f $(CGISCRIPTS) genxref

    -------------Here are the output from make------------

    knoppix@0[lxr-0.31]$ make install
    install --directory /mnt/sda1/lxrbase/http
    install --directory /mnt/sda1/lxrbase/http/lib
    install --directory /mnt/sda1/lxrbase/http/lib/LXR
    install --directory /mnt/sda1/lxrbase/bin
    install --directory /mnt/sda1/lxrbase/source
    install --mode 755 find ident search diff source /mnt/sda1/lxrbase/http/
    install --mode 750 genxref /mnt/sda1/lxrbase/bin/
    install --mode 755 Common.pm Config.pm /mnt/sda1/lxrbase/http/lib/LXR
    install --mode 755 SimpleParse.pm /mnt/sda1/lxrbase/http/lib/
    install --mode 644 http/* /mnt/sda1/lxrbase/http/
    install: cannot stat `http/*': No such file or directory
    make: *** [install] Error 1

     
    • GinEric

      GinEric - 2005-10-14

      For your question, I think either you have ending "/" where none should be, or, you have one without "/" where one should be.

      That is `http/*` either hit and end or the `/LXR` should be `/LXR/` in the second set of install commands.

      "Cannot stat" is the same as cannot file files and/or directories."

      But, what I want to know, is going from version 0.3 to version 0.9.4
      where did the configure script go?  Was the name of the configure script changed or something?  Why are there no instructions on how to make now?

      I'll have to ask again in another post.

      lxr is great once it works.

       
    • Roland Bengtsson

      Thanks for your answer. Of course I want something usable. So your advice is to use 0.9.4 instead of 0.31?

      Anyway I have tried a bit with 0.9.4. This fails...
      I have tried to read the instructions in INSTALL and the history behind lxr in HACKING.

      The history behind my interest for lxr is this:
      I have just start to work with a large server/client application written in Delphi. It's around 1,5 millons lines of badly documented code. Now such a big project is not easy to understand. My idea is to use lxr to increase the understanding of the code as lxr should be independent of language. We must of course be better to document the code too.

      It would be really great to get lxr to parse the delphi code and be able to navigate in the source. But I realize there are a long way to go. I appreciate that I got a reply here even if you also have problem with lxr.

      Regards Roland

       
    • Calvin Austin

      Calvin Austin - 2005-11-03

      I've been using lxr on our site http://developer.spikesource.com/errorbuddy for about a month and will be writing some additional help guides as I have it working with lucene which I like. Plenty more to do though

      lxr.conf is the most important file, you can pretty much dump most of LXR in one directory. You then update the lib subdirectory with the ectags and other perl modules under that directory.

      Next the url you will use for your search. This needs to be used as baseurl and used consistently throughout lxr.

      so for example ./genxref -url http://mymachine/errorbuddy 4.1.13

      baseurl also needs to be http://mymachine/errorbuddy  in lxr.conf

        'baseurl' => 'http://mymachine/errorbuddy',    # Put your URL here

      Next the source layout. lxr wants it to be under a version directory eg 4.1.13 as above
      in lxr.conf                      
      'range' => [qw(4.1.13)],

      sourceroot in lxr.conf
         'sourceroot' => '/opt/testsource/',

      is where  subdirectory 4.1.13 then lives

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks