#95 Mysql 4 required

v0.9.3
closed-fixed
5
2005-01-05
2004-09-21
Anonymous
No

The libraries for Mysql queries (LXR::Index::Mysql)
makes use of the "DELETE FROM table USING
table_reference .." syntax. This is a MySQL 4.x
feature, so things like purging of the database will
not work using a Mysql 3.x back-end. The requirement
for MySQL 4 should be stated in the documentation

This is found in release 0.9.3, but submitted as a
0.9.1 bug as there is no 0.9.3 bug group yet.

Jon Wilson
jon.wilson@aspex-semi.com

PS. Keep up the good work!

Discussion

  • Malcolm Box

    Malcolm Box - 2005-01-05

    Logged In: YES
    user_id=215386

    This has now been fixed in CVS.

    If you can install the new version and check that it solves your
    problem, then it would be very useful.

    Thanks for reporting this defect and helping to make LXR better.

     
  • Malcolm Box

    Malcolm Box - 2005-01-05
    • milestone: 186889 --> v0.9.3
    • status: open --> closed-fixed
     

Log in to post a comment.