#25 Shouldn't install global signal handlers

current_cvs
closed-wont-fix
Browsing (93)
7
2009-03-26
2001-10-31
Malcolm Box
No

Currently Common.pm installs global signal handlers for
DIE and WARN. This means that all scripts running
under mod_perl will use these handlers, even if they
are not part of LXR.

This is wrong.

Discussion

  • Malcolm Box

    Malcolm Box - 2001-11-17
    • assigned_to: nobody --> mbox
     
  • Malcolm Box

    Malcolm Box - 2009-03-26

    The whole of the browsing interface to LXR needs to be rewritten as current system is a bit of a mess. Signal handlers are the least of the problems :)

     
  • Malcolm Box

    Malcolm Box - 2009-03-26
    • status: open --> closed-wont-fix
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks