#233 Identifier search does not work

Lukasz M

I have just installed version 1.1. I haven't really change much in a setup from previous releases. I am unable to view the "Identifier Search" page. I get following error in apache logs:
[Sun Apr 07 15:22:43 2013] [error] Type of arg 1 to push must be array (not hash element) at /usr/share/lxr/ident line 419, near "])"\nType of arg 1 to push must be array (not hash element) at /usr/share/lxr/ident line 485, near "])"\n


  • Andre-Littoz

    Andre-Littoz - 2013-04-08

    Caused by subtle differences in Perl interpreter.
    But the offending lines are not fully compliant with Perl semantics because they use "references" without explicitly telling so. In both lines, embed the first arg to function push (i.e. the array into which to push the second arg) inside @{ } delimiters.
    Will be fixed with 1.2.0 release.

  • Andre-Littoz

    Andre-Littoz - 2013-04-08
    • status: open --> pending
    • assigned_to: Andre-Littoz
    • priority: 2 --> 8
  • Andre-Littoz

    Andre-Littoz - 2013-04-08
    • status: pending --> closed
      Corrected in CVS
    Last edit: Andre-Littoz 2013-04-08
  • Andre-Littoz

    Andre-Littoz - 2013-08-31
    • status: closed --> closed-fixed

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks