#228 Apache 2.4, new access controls

current_cvs
closed-fixed
None
5
2013-01-22
2013-01-19
No

Apache 2.4 uses now Require ... instead of Order, Allow, Deny for access control.

apache-server.conf and htaccess-generic must be modified to use new directives otherwise access is denied with HTML error 403.

Discussion

  • Andre-Littoz

    Andre-Littoz - 2013-01-22
    • status: open --> closed-fixed
     
  • Andre-Littoz

    Andre-Littoz - 2013-01-22

    Since 2.4 access controls using Require are not backward compatible with 2.2, it is necessary to add #@IF/#@ENDIF blocks to selectively include these control directives.

    A new question is added to the configuration process to get Apache version from user. Also, htaccess is no longer simply copied to LXR root directory but undergoes macro expansion.

    Fixed in CVS for 1.1 release.

     

Log in to post a comment.