Another instance running?

  • Mac

    Mac - 2011-08-07

    I installed and got the java message box "Another instance exists" with the message "Another instance of application is still running."

    I then used the, re-did the Same result.

    This in on a Fedora 15, 32 bit, 2.6 kernel. Install was from an LXDE Live CD spin with very minimal options up.

    I'm not much on java, but if you have thoughts on how to get a java console up, I can see what looks to be the real problem.

    Or ….?

  • Cakra Komci

    Cakra Komci - 2011-08-08

    The application tries to take port 52011 when first run. Then another instance tries to take the same port and if it is taken, it pops message "Another instance exists…". However, it is possible that on your machine an exception occurs for some other reason (not the one that the port is already taken). If this message continues after rebooting your machine, I'll send you a special version of application for you, where this "bug" will be fixed, or I may as well publish that version as a new standard one.

    Anyway, let me know so that I can send you a quick fix. I would send you just the JAR file which you would replace in /opt/lxmed/LXMenuEditor.jar

  • Aquila Rubra

    Aquila Rubra - 2011-09-19

    Hello, I have the same problem. I don't see anything running on port 52011. I tried to kill all the processes I could, but it still give the same error. Can you send me the special version? Thanks.

  • Cakra Komci

    Cakra Komci - 2011-09-20

    Please send me your e-mail so I can send you a special version.

  • Chuck H.

    Chuck H. - 2011-12-15

    I am also having this same issue with OpenSUSE 12.1 with the LXDE desktop installed. It appears that LXDE has LXMED installed as part of the default installation. I am running the 64 bit version in a Virtual Box VM.

    I attempt to run the main menu editor immediately after booting, so I'm not sure if another process is using that port or not. If you could send me the special version that you mentioned, i'll try it and report back here as to the results.


                    Chuck H.

  • Cakra Komci

    Cakra Komci - 2011-12-16

    Yes, of course I can send you a special version. Just e-mail me, so that I can send to you as attachment.

  • Chuck H.

    Chuck H. - 2012-01-04

    I tried a pm here to send my email address and also sent an email to this address -->

    could you tell me how to email you if those do not work ?


                         Chuck H.

  • Cakra Komci

    Cakra Komci - 2012-01-04

    Hi Chuck. I got your mail. I have sent you a special version.

  • sideburns

    sideburns - 2013-04-05

    I just installed this on my desktop after reinstalling Fedora 17.  It worked fine on the old installation, as it does on my laptop.  At least, it did after replacing gksu with beesu.  Alas, I'm still getting stuck by this bug.  Please send a fixed copy to, as I really need it.  (BTW, why does a program that doesn't use the network need to reserve a port?)

  • Cakra Komci

    Cakra Komci - 2013-04-05

    Have you installed latest version? I removed port reserving since number of users complained about it. The reason I did it before is that I wanted to ensure only one instance of application runs.

  • sideburns

    sideburns - 2013-04-05

    Well, have it create a lock file in /run/lock and delete it when it exits.  That way you can delete the file to get it unstuck, without needing to reboot, and if you don't, /run goes away when you reboot.  BTW, is there a way to clear that port without rebooting?


Log in to post a comment.