#455 [lxsession]lower nonsense libgee 0.8 again

-
closed-fixed
nobody
None
5
2014-11-15
2013-09-15
marguerite
No

I see in a commit you increase the dependency version for libgee.

Which makes no sense in reality. it just make us have no single backward compability at all.

Because in major released distributions, they still have 0.6

I think only the recently released Ubuntu 13.10 may ship 0.8 by default.

So no one can have LXDE updates in that case when a bug in 0.4.9.2 (you rewrite dbus in logout to make it can shutdown) needs an update to git version.

And it's actually no sense, because as I can see, the code and behavior doesn't change at all.

Related

lxsession: lxsession

Discussion

  • marguerite

    marguerite - 2013-09-15

    I mean, if we bump 0.8,

    Actually we rejected all Debian/ all openSUSE / all Fedora released versions (not Alpha/Beta or Factory, but those have been released but still in lifecycle). which are installed on old computers that is just the target of a lightweight desktop environment.

    So we'd better make a condition to judge if they have 0.8 (my patch doesn't have this, because I don't know how to code this part)

     
  • gilir

    gilir - 2014-11-14
    • status: open --> closed-fixed
    • Group: --> Unstable (example)
     
  • gilir

    gilir - 2014-11-14

    Thanks for the patch. libgee is no longer require on git.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks