When I start "lxservices", it results the same error here on Arch64bit. Using the PKGBUILD. In your Script you are checking rcS.d,rc0.d and so on, on Archlinux there is just /etc/rc.d/.

When I comment all "get_runlevel" and th next for loop, then The GUI starts, but I can't do anything, because it gets nothing to play with.

* every admin configuration fails because I have no su-to-root.
* lxfontconfig.py Not found
* apt-leo. Not found, of course, I think there should be a distro check and the right Manager should be started then. I'm thinking of a text entry for the searched software, which passes the entered text to the package manager "pacman, yum, ...".
* I don't have lxsession-edit installed, so it couldn't be started, Maybe something like red statusbar could appear at the bottom of lxcc. Saying "LXsessionEdit not found, please install "lxsession-edit".

Will test it more intensively later.


On Tue, Jun 29, 2010 at 7:02 AM, Gour <gour@gour-nitai.com> wrote:
On Mon, 28 Jun 2010 21:11:47 +0200
>>>>>> "YUP" == YUP <yupadmin@gmail.com> wrote:

YUP> Hi all, just to inform, that lxdamin package for Archlinux is in
YUP> AUR: http://aur.archlinux.org/packages.php?ID=38520 . It still
YUP> uses github git repository, I will change it in the future when it
YUP> appear in SF.

Thanks for the package.

I did not follow all the discussion here and tried to run one of the
scripts listed by 'pacman -Ql':

[gour@gaura-nitai gour] lxservices
** Message: pygobject_register_sinkfunc is deprecated (GtkWindow)
** Message: pygobject_register_sinkfunc is deprecated (GtkInvisible)
** Message: pygobject_register_sinkfunc is deprecated (GtkObject)
Traceback (most recent call last):
 File "/usr/bin/lxservices", line 280, in <module>
 File "/usr/bin/lxservices", line 205, in __init__
 File "/usr/bin/lxservices", line 136, in get_runlevel
   for i in os.listdir(pathname):
OSError: [Errno 2] No such file or directory: '/etc/rcS.d'

It looks like some stuff is hard-coded?



Gour  | Hlapicina, Croatia  | GPG key: F96FF5F6

This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
Lxde-list mailing list