#10 can't compile 0.2.6

closed-accepted
PCMan
None
5
2009-01-26
2008-02-26
No

I'm not able to build lxpanel. Compilation of 0.2.6 version ends with:

i686-mipld-linux-gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I../plugins -DPACKAGE_LIB_DIR=\""/usr/lib"\" -DPACKAGE_DATA_DIR=\""/usr/share"\" -DPACKAGE_BIN_DIR=\""/usr/bin"\" -DPACKAGE_LOCALE_DIR=\""/usr/share/locale"\" -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -DG_DISABLE_CAST_CHECKS -O2 -fno-strict-aliasing -fwrapv -march=i686 -mtune=pentium4 -gdwarf-2 -g2 -MT fixedtip.o -MD -MP -MF .deps/fixedtip.Tpo -c -o fixedtip.o `test -f 'systray/fixedtip.c' || echo './'`systray/fixedtip.c
systray/fixedtip.c:152: error: conflicting types for 'fixed_tip_hide'
systray/fixedtip.c:34: error: previous implicit declaration of 'fixed_tip_hide' was here
make[3]: *** [fixedtip.o] Error 1

gcc 3.4.6, gtk+ 2.12.8

Discussion

  • Fred Chien

    Fred Chien - 2008-03-01

    Logged In: YES
    user_id=319997
    Originator: NO

    Try last version from svn.
    We fixed some problems about compile.

    Fred.

     
  • Fryderyk Dziarmagowski

    Logged In: YES
    user_id=904796
    Originator: YES

    svn trunk causes same error. It's caused by changes introduced in fixedtip.h header (2.4.0 -> 2.5.0).
    I've copied fixedtip.c from gnome-panel and I can compile it now a bit more, until this appears:
    /home/users/builder/rpm/BUILD/lxpanel-0.2.7.2/src/systray/tray.c:81: undefined reference to `fixed_tip_show'
    tray.o: In function `tray_destructor':
    /home/users/builder/rpm/BUILD/lxpanel-0.2.7.2/src/systray/tray.c:102: undefined reference to `fixed_tip_hide'
    /home/users/builder/rpm/BUILD/lxpanel-0.2.7.2/src/systray/tray.c:102: undefined reference to `fixed_tip_hide'

    Some commits are missing?

     
  • Fryderyk Dziarmagowski

    Logged In: YES
    user_id=904796
    Originator: YES

    commenting out fixed_tip_{show,hide} tray.c and copying more recent fixedtip.c (from gnome-panel) solves the problem for me.

     
  • Jim Huang

    Jim Huang - 2008-03-07

    Logged In: YES
    user_id=1123368
    Originator: NO

    FIXED in svn head.

     
  • Jim Huang

    Jim Huang - 2008-03-07
    • status: open --> closed
     
  • Fryderyk Dziarmagowski

    Logged In: YES
    user_id=904796
    Originator: YES

    Still not fixed in 0.2.8, same build error.

     
  • Fryderyk Dziarmagowski

    • status: closed --> open
     
  • Fryderyk Dziarmagowski

    Logged In: YES
    user_id=904796
    Originator: YES

    Attached patch solves the build problem.
    File Added: lxpanel-gcc34.patch

     
  • Fryderyk Dziarmagowski

    Logged In: YES
    user_id=904796
    Originator: YES

    Attached updated patch for 0.3.5.4
    This version introduced some new problems, fixed with this patch.
    There are still tons of warnings about incompatible pointer type.

    File Added: lxpanel-gcc34.patch

     
  • Fryderyk Dziarmagowski

    Logged In: YES
    user_id=904796
    Originator: YES

    ping
    File Added: lxpanel-gcc34.patch

     
  • PCMan

    PCMan - 2008-06-27
    • status: open --> open-out-of-date
     
  • PCMan

    PCMan - 2008-06-27

    Logged In: YES
    user_id=1110932
    Originator: NO

    Does this happen in lxpanel 0.3.7?

     
  • Fryderyk Dziarmagowski

    Logged In: YES
    user_id=904796
    Originator: YES

    It is still present in 0.3.8. Last patch applies cleanly and solves the issue.

     
  • Fryderyk Dziarmagowski

    Reordering declarations works, but right way to do it is to declare prototypes.
    Replaced old patch with correct one.

    Nothing happens here since months, is lxpanel still developed?
    File Added: lxpanel-missing-prototypes.patch

     
  • Fryderyk Dziarmagowski

    Previous patch applies cleanly to 0.3.99
    ping!

     
  • PCMan

    PCMan - 2009-01-26
    • assigned_to: nobody --> pcmanx
    • status: open-out-of-date --> closed-accepted
     
  • PCMan

    PCMan - 2009-01-26

    The patch is accepted.
    Thank you very much.

     

Log in to post a comment.