Mount Failed: cannot open sha

  • statik213

    statik213 - 2005-02-06

    I just installed lufs and what an awesome concept!
    Anywayz, I tried to mount an ftp folder on another machine on my LAN like so:

    lufsmount ftp://viz:***@chimera/linux cc

    And I got this error msg: cannot open shared object file: No such file or directory
    unsupported file system: ftp

    Anyone know what to do?
    I have Fedora Core 3 that I just upgraded from FC2, and that caused some similiar problems wiht Samba as well...  But since this is a clean new install on FC3, should have been installed as well..

    Thanks in advance.

    • Joni

      Joni - 2005-02-06


      I had the same problem with FC2 a while ago. You should add the directory that resides in to /etc/ and run ldconfig.

      Hope this helps.

      • statik213

        statik213 - 2005-02-06

        Well, I found the files under /root/rpm/lufs-ver/filesystems/ftpfs/.libs

        Now each filesystem that lufs suports is in a seperate subfolder, do i need to add each one seperately to /etc/  so that i can use them?

        • Joni

          Joni - 2005-02-06

          Hmm did you use an rpm? I just compiled the tarball and this is what I did:

          First patch the kernel to include the lufs kernel module and then compile lufs:

          $ ./configure --disable-kernel-support
          $ make
          $ make install

          $ vi /etc/fstab:

          none   /mnt/ftpserver  lufs fs=ftpfs,host=,username=user,password=pass   0 0

          $ mount /mnt/ftpserver

          Add /usr/local/lib to /etc/ld.conf and then run ldconf.

          So I guess the standard install dir for lufs is /usr/local/lib...

          Good luck!

          • statik213

            statik213 - 2005-02-06

            I did not see how to patch the kernal module. I just followed the instructions in the INSTALL file and did only this:

            $ ./configure
            $ make
            $ make install

            How did you install it? I'm not sure how to patch the kernal with lufs module. I'm a little new to linux, so bear with me.

            Thanks for all the help so far!

            • Joni

              Joni - 2005-02-07

              I did the kernel patch because the lufs somehow couldn't compile the kernel module (probably because it couldn't find the sources for the kernel I worked with). If it does compile with no problems than this should not really be necessary...

              Patch kernel for lufs module:

              Download the lufs kernel 2.6 patch and download linux kernel (I tested 2.6.8 which worked, 2.6.9 did not work, didn't test with 2.6.10 )

              $ tar zxvf linux-2.6.8
              $ cd linux-2.6.8
              $ cp /boot/config-2.6.5-1.358 ./.config
              $ make oldconfig
              $ zcat /download/lufs-0.9.7-2.6.0-test9.patch.gz | patch -Np1
              $ make menuconfig

              Enable lufs module (filesystems->misc.filesystems->lufs)

              $ make bzImage
              $ make modules
              $ make modules_install
              $ cp arch/i386/bzImage /boot/linux-2.6.8
              $ mkinitrd /boot/linux-2.6.8.img 2.6.8

              and add the new kernel to grub or other boot loader.

    • Kim Gybels

      Kim Gybels - 2005-03-22

      lufsmount ftpfs://viz:***@chimera/linux cc

      The protocol name is used do dynamically load the correct library for it. Stupid that it doesnt automaticaly appends "fs" for you :)

      • statik213

        statik213 - 2005-03-22

        Didn't understand what you meant, could you explain please?


Log in to post a comment.