'make install' problem...

Help
Anonymous
2003-08-14
2003-08-18
  • Anonymous

    Anonymous - 2003-08-14

    Configure is OK, make is OK, but 'make install' fails...
    I have recently upgraded my system from RH 8 to 9, thus I've had to recompile lufs to fit the new kernel.  When I try to run 'make install' it fails. Here is what it says:

    Making install in kernel
    make[1]: Entering directory `/home/colberg/temp/lufs-0.9.5/kernel'
    Making install in Linux
    make[2]: Entering directory `/home/colberg/temp/lufs-0.9.5/kernel/Linux'
    Making install in 2.4
    make[3]: Entering directory `/home/colberg/temp/lufs-0.9.5/kernel/Linux/2.4'
    make[4]: Entering directory `/home/colberg/temp/lufs-0.9.5/kernel/Linux/2.4'
    make[4]: Nothing to be done for `install-exec-am'.
    /bin/sh ../../../config/mkinstalldirs /lib/modules/2.4.20-8/kernel/fs/lufs
      /bin/sh ../../../libtool --mode=install /usr/bin/install -c lufs.o /lib/modules/2.4.20-8/kernel/fs/lufs/lufs.o
    /usr/bin/install -c lufs.o /lib/modules/2.4.20-8/kernel/fs/lufs/lufs.o
    make  install-data-hook
    make[5]: Entering directory `/home/colberg/temp/lufs-0.9.5/kernel/Linux/2.4'
    depmod -aq
    make[5]: depmod: Command not found
    make[5]: *** [install-data-hook] Error 127
    make[5]: Leaving directory `/home/colberg/temp/lufs-0.9.5/kernel/Linux/2.4'
    make[4]: *** [install-data-am] Error 2
    make[4]: Leaving directory `/home/colberg/temp/lufs-0.9.5/kernel/Linux/2.4'
    make[3]: *** [install-am] Error 2
    make[3]: Leaving directory `/home/colberg/temp/lufs-0.9.5/kernel/Linux/2.4'
    make[2]: *** [install-recursive] Error 1
    make[2]: Leaving directory `/home/colberg/temp/lufs-0.9.5/kernel/Linux'
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/home/colberg/temp/lufs-0.9.5/kernel'
    make: *** [install-recursive] Error 1

    The old lufs-version (the on which worked with RH8 and the older kernel) is still there, can I remove it, do I need to?

    My kernel-version is now 2.4.20-8

    Any help is welcome

    Mikkel

     
    • Ionut Morar

      Ionut Morar - 2003-08-18

      See the line where it says "make[5]: depmod: Command not found"? That's your problem. Check why make can't find the depmod command. Do you have it in your PATH? And by the way - do you have modutils installed? That's where depmod comes from...

      Ionut

       

Log in to post a comment.