basic help required

Help
2002-09-15
2002-09-16
  • Peter Lupus

    Peter Lupus - 2002-09-15

    Hello, i think i have all configured properly (ssh automatic authentification, lufs module appears in lsmod, lufsd appears in ps- aux, /mnt/lufs directory created) but when i try to mount it says :

    mount: wrong fs type, bad option, bad superblock on none, or too many mounted file systems

    this is my syntax (with ./lufsmount and mount it says the same error) :

    ./lufsmount sshfs://monsy@mydomain.net /mnt/lufs --fmask=444 --dmask=555

    mount -t lufs none /mnt/lufs -o nosuid,fs=sshfs,host=mydomain.net,username=monsy,fmode=444,dmode=555

    the lufsd.err file contains :

    command-line: line 0: Bad configuration option: ClearAllForwardings
    [550](recv_packet)packet too big!
    [550](connect)failed to read version!
    [550](processConnection)could not process the request

    Does the lufs.conf file needs to exist ?
    Does an internet sharing network can stop lufs to work ?

    Thanks !
    Simon

     
    • Anonymous - 2002-09-16

      Same thing first happened to me. Then I rebuilt with debugging and kernel-debugging (./configure --enable-debug --enable-kdebug) to take a closer look at the error messages. Turned out my (old) ssh version didn't understand the options thrown at it by lufs. So I upgraded ssh and it worked. So: if you don't have a recent version of ssh (older than 0.3.0), upgrade. If you do, try enabling the debugging. It might give a hint.

      Erik.

       

Log in to post a comment.