Hi Carl, gcov-kernel 2.6 does allow code coverage in dynamic kernel modules.   You should ensure you have  version 3.0 or greater of the module-init-tools on your system.  Source can be found at  http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/


Regards.




Hebert Carl-G49426 <carl.hebert@motorola.com>
Sent by: ltp-coverage-admin@lists.sourceforge.net

09/15/2004 10:24 AM

       
        To:        "'ltp-coverage@lists.sourceforge.net'" <ltp-coverage@lists.sourceforge.net>
        cc:        
        Subject:        [Ltp-coverage] Gcov kernel module



The readme at http://ltp.sourceforge.net/coverage/gcov-kernel.readme states that for coverage for dynamic kernel modules, you need a modutils patch in addition to the gcov patch.  The gcov download page only has a gcov patch for the 2.6 kernel.  There is no patch for modutils.  My question is this:
 
Does the the gcov 2.6 patch allow for code coverage in dynamic kernel modules, or is this feature no longer supported?  Thank you.
 
Carl