Hi


i'm facing problem in dns inverse query for IPv6.
As per the test setup, i have my two machines connected
in LAN...both the machines are Montavista Linux 2.4.20_mvl31-pc_target.
One of them acting as a server & another as client. In server machine
i have installed bind 9.2.4 which is IPv6 aware. In client machine i have configured
/etc/resolv.conf  like

nameserver        <link-local address of server machine>

Now my normal (standard) queries are working fine like,

[root@localhost root]# dig +qr ipv6.domain AAAA

; <<>> DiG 9.2.1 <<>> +qr ipv6.domain AAAA
;; global options:  printcmd
;; Sending:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50051
;; flags: rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ipv6.domain.                   IN      AAAA

;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50051
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;ipv6.domain.                   IN      AAAA

;; ANSWER SECTION:
ipv6.domain.            86400   IN      AAAA    fe80::210:b5ff:fea7:f057

;; AUTHORITY SECTION:
ipv6.domain.            86400   IN      NS      ipv6.domain.

;; ADDITIONAL SECTION:
ipv6.domain.            86400   IN      A       127.0.0.1

;; Query time: 5 msec
;; SERVER: fe80::210:b5ff:fea7:f057#53(fe80::210:b5ff:fea7:f057)
;; WHEN: Thu Sep 15 21:00:45 2005
;; MSG SIZE  rcvd: 87

But for inverse query I have configured /etc/named.conf in server

zone "7.5.0.f.7.a.e.f.f.f.5.b.0.1.2.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.e.f.ip6.arpa." IN {
        type master;
        file "rev_file";
        allow-query { my-net; };
};

and corresponding "rev_file" in  /var/named

$TTL    86400
@       IN      SOA     ipv6.domain. root.ipv6.domain.  (
                                      1997022700 ; Serial
                                      28800      ; Refresh
                                      14400      ; Retry
                                      3600000    ; Expire
                                      86400 )    ; Minimum
              IN      NS      ipv6.domain.

$ORIGIN 0.0.0.0.0.0.0.0.0.0.0.0.0.8.e.f.ip6.arpa.

7.5.0.f.7.a.e.f.f.f.5.b.0.1.2.0 IN PTR ipv6.domain.

but whenever i do inverse query always i get SERVFAIL as status like

[root@localhost root]# dig -x fe80::210:b5ff:fea7:f057

; <<>> DiG 9.2.1 <<>> -x fe80::210:b5ff:fea7:f057
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 49846
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;\[xFE800000000000000210B5FFFEA7F057/128].ip6.arpa. IN PTR

;; Query time: 1006 msec
;; SERVER: fe80::210:b5ff:fea7:f057#53(fe80::210:b5ff:fea7:f057)
;; WHEN: Thu Sep 15 20:31:38 2005
;; MSG SIZE  rcvd: 44


but the same inverse query works fine for IPv4.....
Actually i'm not finding what exactly might be the reason...
is it because of the format which i followed while
configuring /etc/named.conf & corresponding /var/named/rev_file.....
or something else.....plz comment...


thanking u

Sanjib



______________________________________________________________________