Hi Peter,

 

This got resolved when i tried this in KERNEL/mm/Makefile

GCOV_PROFILE := n

 

So basically some issue with KERNEL/mm/vmstat.gcno... right?

 

Now i am able to do a complete kernel run.

 

Thanks & Regards,

Shinto

 

-----Original Message-----
From: "Peter Oberparleiter" <oberpar@linux.vnet.ibm.com>
Sent: Wednesday, April 9, 2014 6:01pm
To: shinto.john@smartplayin.com, "Naresh Kamboju" <naresh.kamboju@linaro.org>
Cc: ltp-coverage@lists.sourceforge.net, "ltp-list" <ltp-list@lists.sourceforge.net>
Subject: Re: [Ltp-coverage] running LCOV/LTP on Beagle Bone Black - Cannot Allocate Memory Error

On 09.04.2014 11:18, shinto.john@smartplayin.com wrote:
> now while running "lcov -c -o coverage.info", this runs for ~5 minutes
> without any issues and then is stuck at this below*red *point for long
> time and never exits.
>
> So i did ctrl-C and tried the "genhtml coverage.info -o out" and it worked.
>
> I could see the LCOV report(Attached index.html) in "out" folder.
>
> But looks like complete kernel folders are not there in the LCOV report
> as it was stuck at below point.
>
> Any comments?
>
> include/asm-generic/bitops/arch_hweight.h:source file is newer than
> graph file '/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/mm/vmstat.gc'
> /home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/arch/arm/include/asm/bitops.h:source
> file is newer than graph file '/home/mallikarjun.bc/LTP'
> include/linux/workqueue.h:source file is newer than graph file
> '/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/mm/vmstat.gcno'
> include/linux/nodemask.h:source file is newer than graph file
> '/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/mm/vmstat.gcno'
> *include/linux/kernel.h:source file is newer than graph file
> '/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/mm/vmstat.gcno'*

Try running top while lcov is stuck and see if there's a process using
up a lot of CPU time. It might be that you are affected by a gcov bug.

--
Peter Oberparleiter
Linux on System z Development - IBM Germany