Hi Peter/Naresh,

 

good news!!

 

After Applying  the gcov 4.7 patches on kernel/gcov, and enabled CONFIG_GCOV_FORMAT_4_7 the issue with gcno is resolved.

so it was due to the version incompatibility as you told.

 

now while running "lcov -c -o coverage.info", this runs for ~5 minutes without any issues and then is stuck at this below red point for long time and never exits.

So i did ctrl-C and tried the "genhtml coverage.info -o out" and it worked.

I could see the LCOV report(Attached index.html) in "out" folder.

But looks like complete kernel folders are not there in the LCOV report as it was stuck at below point.

Any comments?

 

include/asm-generic/bitops/arch_hweight.h:source file is newer than graph file '/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/mm/vmstat.gc'
/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/arch/arm/include/asm/bitops.h:source file is newer than graph file '/home/mallikarjun.bc/LTP'
include/linux/workqueue.h:source file is newer than graph file '/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/mm/vmstat.gcno'
include/linux/nodemask.h:source file is newer than graph file '/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/mm/vmstat.gcno'
include/linux/kernel.h:source file is newer than graph file '/home/mallikarjun.bc/LTP/Download/linux-dev/KERNEL/mm/vmstat.gcno'

Thanks very much both of you for the help.

 

Regards,

Shinto

 

-----Original Message-----
From: "Naresh Kamboju" <naresh.kamboju@linaro.org>
Sent: Wednesday, April 9, 2014 10:12am
To: shinto.john@smartplayin.com, "Peter Oberparleiter" <oberpar@linux.vnet.ibm.com>
Cc: "ltp-list" <ltp-list@lists.sourceforge.net>, "ltp-coverage" <ltp-coverage@lists.sourceforge.net>
Subject: Re: [Ltp-coverage] running LCOV/LTP on Beagle Bone Black - Cannot Allocate Memory Error

hi Shinto,

> Hi Peter,
>
> Thanks for identifying the issue.
> I checked my kernel source code and there is only gcc_3_4.c present in kernel/gcov folder and gcc_4_7.c is NOT present. So as you suggested i will have to upgrade to higher version.
>
> I will check with the latest kernel with GCOV 4.7 on beagle bone black and let you know the result.
>
> currently i use below steps for downloading the kernel source for beagle bone black.
>
> git clone git://github.com/RobertCNelson/linux-dev.git
> cd linux-dev/
> Checkout v3.8.x branch (full cape support):
>
> ~/linux-dev
> git checkout origin/am33x-v3.8 -b tmp

You may use latest linaro arm tool chain.
http://releases.linaro.org/14.03/components/toolchain/binaries/gcc-linaro-arm-linux-gnueabihf-4.8-2014.03_linux.tar.bz2

> ~/linux-dev
> ./build_kernel.sh
> Regards,
> Shinto