Logged In: NO

As the message suggests, you need to edit the environment.rb file to RAILS_GEM_VERSION=1.2.1. Without doing that, your app is trying to load the 1.16 version of rails which doesn't exist in the 1.2.1 bundle.