WSUS Error 8024000F due to LUP update


    ORNAGHI - 2014-04-22


    I have a WSUS server on Windows Server 2008 R2

    Since several days, all computers are unable to synchronize update with WSUS Server (even the Windows 2008 where WSUS is installed).

    If I run synchronization manually, I'm getting the following error : 0x8024000f.

    I have followed the KB971058 without success.

    If I run a synchronisation to Microsoft Update directly, it works without any problem.

    I have enable verbose logging in Windowsupdate.log.

    I'm getting the following error :

    WARNING: cycle detected when evaluate relationships for update {78D9EDAF-B69B-4866-8A0E-D52AF208AD30}.1

    I have found that the update is from Local Update Publisher.

    This update is a FlashPlayer 12 plugin update which has been replaced by another one (version 12 replaced by version 13).

    So, I have delete the replacement update, and the update itself, but it doesn't works.

    I don't understand why because the update 78D9EDAF-B69B-4866-8A0E-D52AF208AD30, is no longer available on LUP.

    Many thanks in advance for your help.
    Best regards.


    ORNAGHI - 2014-04-24


    I have resolved my problem.

    On the WSUS server :
    I have deleted all references to the update 78D9EDAF-B69B-4866-8A0E-D52AF208AD30 in the table "tblDeadDeployment" of WSUS.

    On all computers were error 0x8024000F appears :
    1) Stop Windows update service
    2) Then It's necessary to delete all files and directory in "c\windows\SoftwareDistribution" or you can delete the directory "SoftwareDistribution" directly.
    3) Start Windows update service

    If you have many computers with the problem, you can create a batch file like :

    sc \ComputerName stop wuauserv
    rmdir /s /q \ComputerName\c$\windows\SoftwareDistribution
    sc \ComputerName start wuauserv

    The batch must be run from the WSUS server, so you will be sure that you have rights to work with services.
    I have added a "pause" because some computers are slow and Windows update takes too many time to stop, so directory can't be deleted.

    Hope this help.

  • Bryan Dam

    Bryan Dam - 2014-04-24

    Sorry, couldn't reach the sourceforge site the other day. Emptying the SoftwareDistribution folder was going to be my recommendation. Do you know if that worked without first doing the table modifications?

    I'm fairly certain that the warning you got refers to some circular logic in the applicable, installed, supersedes, prerequisite rules. In those cases you should be able to expire the update and the local clients should ignore them. However, if a client has picked it up ... testing is recommended after all ... it might keep installing it for some time until it gets the hint that the update is expired. That is to say, once downloaded the client seems to keep trying to run the install even if the server has expired it. The only recourse is to delete the download or just delete the whole SoftwareDistribution folder.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks