All buttons are grey

  • Schwosh

    Schwosh - 2011-05-31

    I have a question, I just upgraded from v 1.6 to 1.7.2 of CalSync and in v.1.6 I could edit settings etc when I had logged in to the accounts and had auto sync enabled. But now in v.1.7.2 everything in the CalSync windows is grey and no buttons or menus can be clicked on to change settings or anything. So I cant even stop the auto sync to be able to change settings.

    Only way I can change anything is to close the program and then delete the settings file and recreate it from scratch.

    Is this something that's intended to be like this or should I be able to do the same things as in v.1.6?

    Anyone else with the same issue?

  • lidsinker

    lidsinker - 2011-05-31

    Does it say you are successfully logging in?  Does it still sync?  Everything get's disabled during login but should be re-enabled when the login succeeds or fails.

  • Schwosh

    Schwosh - 2011-06-01

    The logging in works, it doesn't say anything about it that might fail anyway, and it do sync and continue each sync interval that I have set.

  • Schwosh

    Schwosh - 2011-06-01

    I can add that it was working exactly as you described when I was using v1.6.

  • lidsinker

    lidsinker - 2011-06-01

    So what happens if you delete the settings file and start from scratch?

  • Schwosh

    Schwosh - 2011-06-07

    When I delete the settings file and start from scratch, at first before I have added the settings I want, just loggin in and start the auto sync. Then it works as it should.

    When I add "Save Password and automatically login", it still works but it doesn't save the Notes password, but all other settings are save as they should. That part in the settings file with the NotesPassword tag is still empty so I still have to login manually to notes.

    If I add the "old" encrypted Notes password I had in the old settings file, then it do login automatically and the syncing works fine too and I can still use buttons and menus.

    But when I add "Automatically start syncing after login" then all menus and buttons will be greyed out in the GUI. It do sync but I cant change anything else in the settings etc.

  • lidsinker

    lidsinker - 2011-06-07

    What happens if you try these stesp?

    1. Delete old settings file.
    2. Open CalSync
    3. Open settings
    4. Check "save passwords and automatically login" box and "Automatically start syncing after login"
    5. Close settings, enter account information and clikc "Login".
    6. Close CalSync
    7. Open CalSync.

    What happens?  Same problems?  Also, click the "Show Verbose Log" box and tell me if any errors show up.

  • Schwosh

    Schwosh - 2011-06-08

    I did all thoose steps, and the same thing happens, right after I did enter all, it worked fine, and after the restart the same thing did happen, and before I did restart it I added the verbose log etc, but for some reason it didnt save that setting, so when I did restart the app the verbose setting wasn't checked. Also I cant copy that log anyway when everything is greyed out. :)

  • Anonymous - 2011-07-20

    I'm am experiencing the same issue as described above. Any fix for this? It's quite annoying to have to delete the settings file and re-enter everything each time I need to restart the program.


  • HuNu

    HuNu - 2011-07-27

    New user experiencing the same symptom - after running calsync & configuring for the first time, all menus and buttons are grayed out.  Deleting "calsync.settings" seems to be the only way to be able to change anything.  Right now I've set it to auto sync every hour, which it seems to do, but when I right click and select "show calsync", everything is grayed out. 

  • Anonymous - 2011-08-02

    Same issue - I posted it below. Plus I have a .NET Framework Error that keeps occurring with no explanation.  Getting a little frustrated, as I'd like to be able to rely on this keeping my calendar syched, and it's *this* close to being golden.

  • Anonymous - 2011-08-17

    I have the same issue. It works great the first time I log in, but if I restart, everything i disabled. In the bottom right it shows Sync Completed!

    It seems to be a setting problem. I will get this problem if both "Save passwords" and "automatically start syncing after login" are checked in  General Options.

    I just unchecked "Automatically start syncing after login" and it works fine.

  • Anonymous - 2011-08-24

    Agreed - once I unchecked the "Auto start" option, I no longer have the issue. 

    I do have to login manually to Lotus Notes - maybe part of the problem is that Notes is not allowing an auto-login from a stored password, hence the automatically starting is not an option?

  • B_CLV4

    B_CLV4 - 2011-10-03

    Hello, user since v1.5, I have the same problem here with v1.7.2, all buttons are grey when using the Autostart option. When unchecked, it works fine, but first sync need to be done manually.

    New version to fix the issue will be appreciated.

  • Steve Short

    Steve Short - 2011-10-10

    Hello, New user (Windows 7 64bit), same issues, greyed out settings boxes, but all is working fine.

  • Francis

    Francis - 2012-01-26

    same problem here.  begin with handle error.. I deleted setting file. re-enter all if you don't turn off computer. once logged off and turned off. error appeared.all gray out in setting.

  • Kerry White

    Kerry White - 2012-01-27

    I have the same problem.  To add to the problem, I have to change my password every 30 days.  I assume calsync is supposed to "ungrey" out when  it has a log-in error, but it doesn't.  It just says something about an error and won't let me open it. 

    I have to go delete the settings file every month and re-enter my information to get it to work.  I would like to be able to uncheck autolog in after i've checked it to be able to update the password.  Please add this feature to 1.7.3

  • Scott

    Scott - 2012-02-03

    +1 To this
    The problem is that the Lotus user / pass is not saved in either local folder or user settings - you can view the contents of the file on app exit and only the Google credentials are saved. There is also no check to prevent the auto-sync on startup with missing Lotus credentials. This causes a hang at startup when auto-sync is installed.

  • jvvy

    jvvy - 2012-02-17

    Here is a workaround:
    When CalSync first starts, it displays the Notice/Help window. At the bottom left of this window, check the "Don't show this window on startup" box before closing.  Now it is safe to choose the "Automatically start syncing after login" setting option. If you've already started auto-sync without checking the "don't show" box, the easiest fix is to stop the application, delete the CalSync.exe.config file in the application folder, start the app, check the box, and enter your settings again.

    I think the permanent fix is in MainForm.RunAfterFormLoad. It currently says

    if (this.IsAutoStartSyncOptionSet && !this.AutoRunAndClose && Properties.Settings.Default.showNotice)

    but probably wants to say

    if (!this.IsAutoStartSyncOptionSet && !this.AutoRunAndClose && Properties.Settings.Default.showNotice)
  • MacPat

    MacPat - 2012-02-20

    based on jwy's information, I tries succesfully the following:
    - Quit CalSync
    - Keep a copy of the file CalSync.seeetings _just in case ;-)
    - Edit the file "_CalSync.seeetings
    " and Modifiy the line #7:   <showNotice>True</showNotice> and replace True by Flase
    - Save
    - Launch CalSync
    - Nothing grayed out anymore !
    - Enjoy

  • Anonymous - 2012-07-03

    Thanks macpat, I've been struggling with this issue for a couple months now and your post solved it.
    much appreciated

  • Anonymous - 2012-07-30

    Corrected using method from jvvy.

    My version (1.7.2) doesn't show the dialogue on start up so I had to manually open the 'Help' menu and check the box from there to no longer show the dialogue on start up.


Log in to post a comment.