Hi Florian,

2012/9/18 Florian Jung <florian.a.jung@web.de>
Hi

once a while ago, i tried to compile MusE on FreeBSD, which after minor
changes succeeded. The produced binary, however, was not able to start
because ALSA could not be properly initalized (which is true, because
freeBSD has no alsa.)

in the last time, there were some changes around the audio subsystem
(which i didn't really follow), so my question is: is MusE still
dependant of ALSA, or can it run in JACK-only environments now? (i think
my problem was that MusE wanted to use ALSAs timer or so.)

ALSA is still very much a dependency. 
It is used both by the sequencer layer (maybe this is optional now?) and the timer.
The alsa timer dependency can easily be worked around if there is some other timer available. I don't know much about bsd, does it have a compatible RTC device? If so the alsa timer can simply be removed.
 
and Robert: you were working on a MacOSX port for MusE a while ago,
true? How did you solve the ALSA-Problem? Have you replaced the ALSA
driver by some MacOSX-specific audio driver, or have you made MusE
JACK-only?

I have tried getting into a usable state several times over the years but never gotten past proof of concept status.
I had it running sometime last year by commenting out all alsa stuff and using the Dummy timer as a temporary timer substitute.

Regards,
Robert