2012/11/22 Tim E. Real <termtech@rogers.com>
On November 21, 2012 06:19:18 PM Tim E. Real wrote:
> On November 21, 2012 07:39:32 PM sayhi2guy@tiscali.co.uk wrote:
> > Hi
> >
> > I have compiled & installed 2.1rc1 on my Bodhi Linux box.  When I
> > load the mess fluidsynth & click on the diamond to show the fluidsynth
> > GUI nothing happens.  I tried the same with mess vam & it also didn't
> > work.  The same process for mess simple synth or for DSSI hexter brings
> > up the GUI.
> >
> > As always, thanks for Muse & any help gratefully
> > received.
> >
> > Guy
> What desktop system does this distro use?
> We had a similar issue from someone running Lubuntu.
> So I installed Lubuntu and discovered that it was the choice
>  of desktop which caused this.
> KDE, Gnome, and the Unity desktop worked OK, while all
>  the others did not.
> The synths windows did not open and the Markers window did not open.
> I am willing to bet that when you try to open the Markers window
>  it does the same thing? (That was the poster's original complaint.)
> So unfortunately I can only recommend you to try another desktop.
> Try KDE, Gnome, Unity, or XFCE which also apparently works.
> Hope this helps.
> Tim.

Not a very satisfactory answer, is it? The original poster didn't think so.
Neither did I.

So I finally fixed it. In SVN trunk now.

* Fixed: Markers and synth windows don't open at all on some desktops
 like Lubuntu.

Solution was combination of REMOVAL of fix for "bug: 2811156 Softsynth
 GUI unclosable..." (of which said removal BY ITSELF DID NOT FIX this problem)
 AND removal of some superfluous show()s.

Yep, Robert that's why the removal didn't work for the original poster and me.
Crud, eh?

Cool! So disregard from my previous mail. :)