Am 2010-05-22 01:41, schrieb Robert Jonsson:
Hi Pieter,

It's kind of late but it seems a good time!?
A midnight spring bath in the garden keeps you awake. ;)

2010/5/21 Pieter Barendrecht <>:
Hi all,

Recently I read that the newest version of MusE will support the MIDI
connections in JACK. Because I start VSTs with FST (I couldn't get DSSI
to work), I would like to install the newest version (from SVN).

I checked it out (number 419 if I remember correctly), and installed the
dependencies mentioned in the README. However, the README seems to be a
little out-of-date (the mentioned website for LibSndFile doesn't exist
anymore, and QT already reached version 4.5).
I installed this version of QT (4.5.3 to be exact), however when I run
"./configure" in the /trunk/MusE directory, it prints this error:
Ah, did it say to get the newest? We try to keep the web somewhat
uptodate but it's probably lagging too.

You need the latest Qt from the 3.x series. Muse 1.x does not support Qt4

checking for QT environment variable QTDIR... yes
checking for QT includes (/usr/share/qt4/include)... no
checking for QT libraries (/usr/share/qt4/lib)... no
checking for QT moc (/usr/share/qt4/bin/moc)... no
checking for QT uic (/usr/share/qt4/bin/uic)... no
configure: error: need qt >= 3.2.0

Even though earlier on I run "export QTDIR=/usr/share/qt4". QT 4 is
backwards compatible with QT 3 (by default), however I couldn't figure
out how to use the "thread"-option while compiling it, maybe that's the
reason why ./configure complains?
By the way, the installation of QT from source is huge! The download was
about 140 MB if I'm not mistaken, but it took about 2 or 3 Gig when it
was installed!
Though you should know that normally you don't need to install
anything from source, just install the accompanying development
package from your repository.


Other installed software versions:
ALSA 1.0.20
GCC 4.4.1
Libsndfile 1.0.20
Jackd 0.118.0
Fluidsynth 1.0.9
And the soundcard is the Intel HDA one.

Oh, I use Ubuntu 9.10 (going to install a clean image of 10.04 this

Any ideas? Thanks in advance!


Lmuse-user mailing list


Lmuse-user mailing list

Hi Pieter,

here is my list of commands to download the dependencies and do the compilation for !!v9.10!!, for v10.04 some of the file names have to be altered.

At the terminal enter step by step:


sudo apt-get install subversion build-essential gcc make cvs

#comment: in the following command you can dismiss "docbook" - it is a large download and only for documentation purpose, which I believe to be outdated"

sudo apt-get install pyqt-tools python-dbus python-qt3 qt3-designer qt3-dev-tools qt3-qtconfig libcap-dev libqt3-headers libqt3-i18n libqt3-mt-dev qt3-assistant qt3-designer qt3-qtconfig automake1.9 cpp-4.4 libtool libjack-dev libsndfile1-dev libfluidsynth-dev fluidsynth-dssi libladspa-ocaml-dev libsamplerate0-dev docbook polymer libltdl7-dev libltdl7 python2.5-dev python-dev python-qt-dev pyro liblash-dev lashd python-all-dev

#comment: add this repo to your repo list. Then from within synaptic-paket administration search for and install all of these
liblo (could be named liblo0 for example)

#The compilation process:

svn co lmuse

cd lmuse/trunk/muse

./ --prefix=/usr

export QTDIR=/usr/share/qt3

#the switch "--enable-arch=pentium4 depends on the architecture of your system!!

./configure --enable-optimize --prefix=/usr --enable-arch=pentium4 --enable-lash --enable-shared --enable-vst --with-docbook-stylesheets=/usr/share/sgml/docbook/dsssl-stylesheets-1.79 --enable-python=yes --with-qt-prefix=/usr/share/qt3 --enable-dssi --enable-osc


sudo make install


Good luck,