First - thx a lot for your wonderful work on lmms. Previously I was fed up setting ardour/jack/realtime kernel, etc. Your software has brought simplicity and fun to composing on linux ;-).
Now the problem/bug report ;-)

I tried to install the new 0.4.0 it via apt-get from the binary repo:

-> added the proper repo to my sources list: deb httpd://ppa.launchpad.net/tobydox/ubuntu hardy main
-> removed any previous package versions with apt-get remove
-> ran apt-get update
-> successfully installed lmms and lmms-common

Then ran apt-get install lmms-extras with the following results:

The following packages have unmet dependencies:
  lmms-extras: Depends: lmms (= 0.4.0~ppa-4) but 0.4.0~ppa-2 is to be installed
E: Broken packages

Anyone came across this one??

-Piotr