I just gave it a try to compile LMMS on cygwin since I do not have *nix @work and have som espare time, well..
At first I downloaded source tarball downloaded from SF, this doesnt even ./configure; it ends with:
checking QTDIR... configure: error: *** QTDIR must be defined, or --with-qtdir option given
I have qt3 devel package from cygwin installed, $QTDIR being set to /usr/lib/qt3; I tried to change it to
/usr/include/qt3, /usr/lib/qt3/lib and such, it didnt help. Also tried to provide --with-qtdir option to configure, but the result is exactly the same..
I also tried to checkout sources from svn as mentioned on wiki, but the checkout fails with
A    lmms/plugins/ladspa_effect/caps/Reverb.h
A    lmms/plugins/ladspa_effect/caps/click.h
A    lmms/plugins/ladspa_effect/caps/money.h
svn: In directory 'lmms/plugins/ladspa_effect/caps'
svn: Can't copy 'lmms/plugins/ladspa_effect/caps/.svn/tmp/text-base/click.h.svn-base' to 'lmms/plugins/ladspa_effect/caps/.svn/tmp/click.h.tmp.tmp': No such file or directory
Thanks for any help/pointers