SourceForge has been redesigned. Learn more.
Close

Ubuntu 12.04: Project MESSAGE: Warning: unknown QT: widgets

Gronaz
2014-02-03
2014-02-03
  • Gronaz

    Gronaz - 2014-02-03

    Hi
    I have libqt4-dev 4.4.8 installed
    I first installed qt-sdk and got a message stating phonon won't be ok because missing phonon-backend-gstreamer and phonon-backend-vlc. Although, qt-sdk installed. Then, wanting to install the 2 missing packages, I got info saying this would uninstall qt-sdk, so I didn't.
    Tried to compile a "pure server" although, but I get this and nothing happens:

    ~/Sources/Jamulus3.3.3$ qmake "CONFIG+=nosound" Jamulus.pro
    Project MESSAGE: Warning: unknown QT: widgets

    Please any advises?
    Thank you for doing this software

    [EDIT]
    I think qt-sdk install and phonon warning is not related:
    I removed qt-sdk, then sudo apt-get autoremove, then reinstalled all in a shoot both qt-sdk and phonon-backend-* + dbg related + phonon itself, and I got the same info/warning "~ [recommending] phonon-backend-gstreamer for this system"
    Although, I still get
    ~/Sources/Jamulus3.3.3$ qmake "CONFIG+=nosound" Jamulus.pro
    Project MESSAGE: Warning: unknown QT: widgets
    on compile.

     
    Last edit: Gronaz 2014-02-03
  • Volker Fischer

    Volker Fischer - 2014-02-03

    You can ignore the warning. The project file is compatible to both, Qt4 and Qt5. "widgets" was added by Qt5. Qt4 shows your warning but still compiles fine.

    If you type "make" after the qmake call, what output do you get?

     
  • Gronaz

    Gronaz - 2014-02-03

    Thank you Volker. This created a number of .h and .o files in my ~/Sources/Jamulus3.3.3 plus a binary Jamulus.
    Is it good practice to move all these elsewhere? /opt maybe?
    [EDIT] Sorry man, all stuck with the qmake error I forgot to look back to look back to the help you already provide (qmake, make clean, make).
    BTW, I also removed the moc_*.cpp files before qmake as advised in the forum.
    Well, I'll redo the whole process.
    Thank you again Volker.

     
    Last edit: Gronaz 2014-02-04

Log in to post a comment.