Snapshot Creation Failed

Help
nji7103
2009-02-21
2013-04-23
  • nji7103

    nji7103 - 2009-02-21

    ============================START============================
    I got the below error after upgrading to .7b. The upgrade fixed my other problem but now I have this new one. Any ideas?

    Detected VMWare Server Installation
    Detected full disk image
    Generating vmx file...
    Generating vmdk file...
    VMX added to VMWare Server Config
    ERROR>     Snapshot Creation Failed
    ERROR>     Problem preparing partition1 for launch
    VM Launch Failed

    External Proc Output: ! REG.EXE VERSION 3.0
    HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware Virtual Disk Development Kit
        InstallPath    REG_SZ    C:\Program Files\VMware\VMware Virtual Disk Development Kit\

    External Process Error:
    Live View 0.7b
    Host Operating System: Windows XP
    Java Version: 1.6
    Executing: [reg, query, "HKLM\SOFTWARE\VMWare, Inc.", /v, Core]
    External Proc Output: ! REG.EXE VERSION 3.0
    HKEY_LOCAL_MACHINE\SOFTWARE\VMWare, Inc.
        Core    REG_SZ    VMware Server Standalone

    External Process Error:
    Executing: [reg, query, "HKLM\SOFTWARE\VMware, Inc.\VMware Server", /v, InstallPath]
    External Proc Output: ! REG.EXE VERSION 3.0
    HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware Server
        InstallPath    REG_SZ    C:\Program Files\VMware\VMware Server\

    External Process Error:
    VMWare Install Type: 1
    VMWare Mount Path: C:\Program Files\VMware\VMware Virtual Disk Development Kit\bin\vmware-mount.exe
    Executing: [reg, query, "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\vmware-mount.exe", /v, Path]
    External Proc Output:
    External Process Error: Error:  The system was unable to find the specified registry key or value

    Ram Size: 512
    System Time: Feb 21, 2009 5:10:21 PM
    Guest OS: auto
    Is Physical Disk: false
    All numeric extensions
    Sorted extensions numerically
    Sorted Input Files [E:\laptop dd image.001, E:\laptop dd image.002, E:\laptop dd image.003, E:\laptop dd image.004]
    vmrun path: C:\Program Files\VMware\VMware Server\..\VMware VIX\vmrun.exe
    Mount Drive Letter: k
    MBR Signature found: almost certainly have an mbr or partition (not garbagefile)
    Num Existing Snapshots 0
    MBR Info:

    33 c0 8e d0 bc 00 7c fb 50 07 50 1f fc be 1b 7c
    bf 1b 06 50 57 b9 e5 01 f3 a4 cb be be 07 b1 04
    38 2c 7c 09 75 15 83 c6 10 e2 f5 cd 18 8b 14 8b
    ee 83 c6 10 49 74 16 38 2c 74 f6 be 10 07 4e ac
    3c 00 74 fa bb 07 00 b4 0e cd 10 eb f2 89 46 25
    96 8a 46 04 b4 06 3c 0e 74 11 b4 0b 3c 0c 74 05
    3a c4 75 2b 40 c6 46 25 06 75 24 bb aa 55 50 b4
    41 cd 13 58 72 16 81 fb 55 aa 75 10 f6 c1 01 74
    0b 8a e0 88 56 24 c7 06 a1 06 eb 1e 88 66 04 bf
    0a 00 b8 01 02 8b dc 33 c9 83 ff 05 7f 03 8b 4e
    25 03 4e 02 cd 13 72 29 be 46 07 81 3e fe 7d 55
    aa 74 5a 83 ef 05 7f da 85 f6 75 83 be 27 07 eb
    8a 98 91 52 99 03 46 08 13 56 0a e8 12 00 5a eb
    d5 4f 74 e4 33 c0 cd 13 eb b8 00 00 80 43 17 12
    56 33 f6 56 56 52 50 06 53 51 be 10 00 56 8b f4
    50 52 b8 00 42 8a 56 24 cd 13 5a 58 8d 64 10 72
    0a 40 75 01 42 80 c7 02 e2 f7 f8 5e c3 eb 74 49
    6e 76 61 6c 69 64 20 70 61 72 74 69 74 69 6f 6e
    20 74 61 62 6c 65 00 45 72 72 6f 72 20 6c 6f 61
    64 69 6e 67 20 6f 70 65 72 61 74 69 6e 67 20 73
    79 73 74 65 6d 00 4d 69 73 73 69 6e 67 20 6f 70
    65 72 61 74 69 6e 67 20 73 79 73 74 65 6d 00 00
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00 00 00 8b fc 1e 57 8b f5 cb 00 00 00 00 00 00
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00 00 00 00 00 00 00 00 1a fb 44 ec 00 00 80 01
    01 00 0c fe bf d8 3f 00 00 00 1b f2 b2 00 00 00
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 55 aa
    Partition 1:
    ====================
    Is Bootable: true
    Begin Head: 1
    Begin Cylinder: 0
    Begin Sector: 1
    Partition Type: 0xc
    End Head: 254
    End Cylinder: 728
    End Sector: 63
    Relative Sector: 63
    Num Sectors: 11727387
    Partition 2:
    ====================
    Is Bootable: false
    Begin Head: 0
    Begin Cylinder: 0
    Begin Sector: 0
    Partition Type: 0x0
    End Head: 0
    End Cylinder: 0
    End Sector: 0
    Relative Sector: 0
    Num Sectors: 0
    Partition 3:
    ====================
    Is Bootable: false
    Begin Head: 0
    Begin Cylinder: 0
    Begin Sector: 0
    Partition Type: 0x0
    End Head: 0
    End Cylinder: 0
    End Sector: 0
    Relative Sector: 0
    Num Sectors: 0
    Partition 4:
    ====================
    Is Bootable: false
    Begin Head: 0
    Begin Cylinder: 0
    Begin Sector: 0
    Partition Type: 0x0
    End Head: 0
    End Cylinder: 0
    End Sector: 0
    Relative Sector: 0
    Num Sectors: 0

    #Static Values
    config.version = "8"
    virtualHW.version = "3"
    floppy0.present = "FALSE"
    displayName="laptop dd image.001"

    #Drive Info
    ide0:0.present = "TRUE"
    ide0:0.fileName = "C:\Documents and Settings\Neal\laptop dd image.001.vmdk"
    ide0:0.deviceType = "disk"
    ide0:0.mode = "persistent"
    ide1:0.present = "TRUE"
    ide1:0.fileName = "auto detect"
    ide1:0.deviceType = "cdrom-raw"

    #User Specified
    memsize="512"
    rtc.starttime="1235257821"
    tools.syncTime="FALSE"
    time.syncronized.continue="FALSE"
    time.syncronized.restore="FALSE"
    time.syncronized.resume.disk="FALSE"
    time.syncronized.resume.memory="FALSE"
    time.syncronized.shrink="FALSE"

    # Disk Descriptor File
    version=1
    CID=fffffffe
    parentCID=ffffffff
    createType="monolithicFlat"

    # Extent description
    RW 3072000 FLAT "E:\laptop dd image.001" 0
    RW 3072000 FLAT "E:\laptop dd image.002" 0
    RW 3072000 FLAT "E:\laptop dd image.003" 0
    RW 2517120 FLAT "E:\laptop dd image.004" 0
    RW 5670 ZERO

    #DDB - Disk Data Base
    ddb.adapterType = "ide"
    ddb.geometry.sectors = "63"
    ddb.geometry.heads = "254"
    ddb.geometry.cylinders = "728"
    ddb.virtualHWVersion = "3"

    Executing: [reg, query, "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders", /v, Common AppData]
    Output: Detected VMWare Server Installation

    Output: Detected full disk image

    Output: Generating vmx file...

    Output: Generating vmdk file...

    External Proc Output: ! REG.EXE VERSION 3.0
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
        Common AppData    REG_SZ    C:\Documents and Settings\All Users\Application Data

    External Process Error:
    Path TO VMServer vm-list: C:\Documents and Settings\All Users\Application Data\VMware\VMware Server\vm-list
    String to add: config "C:\Documents and Settings\Neal\laptop dd image.001.vmx"
    vmx was already in vm-list, skipping append
    Executing: [C:\Program Files\VMware\VMware Server\..\VMware VIX\vmrun.exe, snapshot, C:\Documents and Settings\Neal\laptop dd image.001.vmx]
    Output: VMX added to VMWare Server Config

    External Proc Output: Error: Service type VIX_SERVICEPROVIDER_VMWARE_WORKSTATION was specified, but not installed

    External Process Error:
    Error: Snapshot Creation Failed
    Error: Problem preparing partition1 for launch
    Output: VM Launch Failed

     
    • nji7103

      nji7103 - 2009-02-21

      I am trying to open a windows 98 image. I just found a thing in VMWare that says it can't take a snapshot without an upgrade, is that my problem?

       
    • tvidas

      tvidas - 2009-02-22

      So i searched around for a bit, and almost everything i see about "VIX_SERVICEPROVIDER_VMWARE_WORKSTATION was specified, but not installed" is related to VIX programming and the need to query the installed type (server or workstation) prior to using other VIX functions.  Since LiveView doesn't use VIX directly, I'm thinking that this is an issue with your vmrun.exe binary - which was likely programming using VIX.

      Can you verify that the vmrun binary on your machine is usable?  Based on the posted logfile it's located at C:\Program Files\VMware\VMware VIX\vmrun.exe

      For example can you:
      vmrun.exe -T server1 list
      or
      vmrun.exe -T server1 start <PATH TO AN EXISTING VM>

      remember, if the snapshot portion fails LiveView will fail on purpose instead of continuing to boot the VM.  Without the snapshot changes made while interacting with the VM will result in changes to the image file(s).

      Also, do you have an image of a different OS to try?  (just to verify that everything else - like vmrun.exe is in working order).   I don't have a win98 image handy to try, but i can probably track one down to test with if this issue does end up being Guest OS specific.

      -tim

       
  • Dewey

    Dewey - 2010-01-21

    I found this forum and thread after getting the same error:

    Detected VMWare Workstation installation
    Detected full disk image
    Generating vmx file…
    Generating vmdk file…
    ERROR> Snapshot Creation Failed
    ERROR> Problem preparing partition1 for launch
    The VMWare configuration files have been generated in your chosen output directory
    ========================================
    I am using the fully patched and up-to-date version of Windows XP, SP3.  I am also using VMware Workstation 7.  I have never seen this problem until after I upgraded from VMware Workstation 5.5 to Workstation 7.  I have also tried the aforementioned "vmrun -T server1 list" command.  I the get a "Unable to connect to host.  Error: The system returned an error.  Communication with the virtual machine may have been interrupted" error.  Naturally, I feel that this is at least part of the problem if not all.  Any ideas?  Thanks in advance.

     
  • tvidas

    tvidas - 2010-01-21

    dewey003,

    Are you able to launch any VMs through liveview?

    after you attempt to launch are there any "extra drive letters" mapped? vmware-mount would be able to tell if the virtual disk is still mounted (or you should be able to just observe the extra mapping via windows explorer).

    I think this is most likely due to a change in Workstation. LiveView 0.8 is being beta tested right now, i have a feeling that it may solve your problem…

     
  • Dewey

    Dewey - 2010-01-21

    I didn't try to launch any of the working VMs through LiveView… didn't think of that.  If it makes a difference (I didn't think it would), I was using LiveViewLE 0.7b.  After serveral failed attempts at launching the DD image, I went to plain LiveView 0.7b (not LE), but got the same results.  I have already completely uninstalled VMware and LiveView, and am in the middle of the reinstall where I will try again.  I've used LiveView many times with Workstation 5.5 prior to recently upgrading to Workstation 7, so I wondered if it may have been the install of WS 7… thus this current uninstall and attempted reinstall.  I'll let you know.  THANKS….

     
  • Dewey

    Dewey - 2010-01-21

    It must have been something in my initial installation.  After I uninstalled, then reinstalled ***everything***, this VM created and started without error.  Now I have to boot to something like the Linux Boot disk because the "custodian" of this XP system has locked out off of the accounts through repeated failed logons   Thanks.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks