Having trouble compiling

  • Robert Williams

    Robert Williams - 2009-07-11

    I'm having trouble compiling on OSX 10.5.7
    I have a 2.5Ghz Intel Core 2 Duo
    I copied this line out of the "INSTALL" file.

    robhybrid$ ./configure CC="gcc -arch i386 -arch x86_64 -arch ppc -arch ppc64" \ > CXX="g++ -arch i386 -arch x86_64 -arch ppc -arch ppc64" \ > CPP="gcc -E" CXXCPP="g++ -E"
    checking build system type... i386-apple-darwin9.7.0
    checking host system type... i386-apple-darwin9.7.0
    checking target system type... i386-apple-darwin9.7.0
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... ./install-sh -c -d
    checking for gawk... no
    checking for mawk... no
    checking for nawk... no
    checking for awk... awk
    checking whether make sets $(MAKE)... no
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for style of include used by make... none
    checking for gcc... gcc -arch i386 -arch x86_64 -arch ppc -arch ppc64
    checking for C compiler default output file name...
    configure: error: in /Users/robhybrid/Downloads/lives-1.0.0-pre2': configure: error: C compiler cannot create executables Seeconfig.log' for more details.

    I also tried this with the same result:
    robhybrid$ ./configure CC="gcc -arch x86_64" \ > CXX="g++ -arch x86_64" \ > CPP="gcc -E" CXXCPP="g++ -E"

    • Salsaman

      Salsaman - 2009-07-11

      I think just ,/configure on its own should be enough. The architecture should autodetected.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks