Generate clip from image... never does

  • abruzzopat

    abruzzopat - 2011-09-05

    I'm pretty new to LiVES and appreciate any help you can offer. I'm trying to
    convert an image (jpg) to a clip. The image is already resized to 640X480
    which is the size wanted for the clip.

    I choose "generate clip from image", confirm the size, select the file (a 200k
    jpg) and click ok. I get the dialog box which says "Generating clip from image
    to new clip" and "please wait" with the bouncing progress bar. But it sits
    there forever (I've waited as long as an hour).

    This is on the best machine I have access to (dual quad-core, 8 g RAM), and
    when I monitor system resources before starting the job, there's no change, so
    it does not appear to be a resource issue.

    I've tried a couple different pics... I can open the pics in GIMP or image

    Any suggestions? Does LiVES prefer a certain image file format?


  • Salsaman

    Salsaman - 2011-09-06

    There were a few fixes to this recently, so make sure you are using the latest
    version of LiVES (currently 1.4.6)


  • abruzzopat

    abruzzopat - 2011-09-07

    Thanks Gabriel. I'm actually running 1.4.1 which was what came when I grabbed
    it from the Ubuntu "store". I'll try upgrading and post results.

  • Frank Johnson

    Frank Johnson - 2012-07-17

    I am running 1.6.1 and have exactly the same problem.

    I need two clips, a few seconds eaach made from stills and I cannot get
    Generate clip from still to work at all.

    I ahve tried several different images and image resolutions without success.

    As the OP states, it just sits there and never completes.... even after 8
    hours overnight.

    What's the secret to get this feature to work?


  • Frank Johnson

    Frank Johnson - 2012-07-18

    Developers: I have found my problem with Generate clip from still.

    There is a limit to the length of the command buffer which is passed to
    Smogrify ). I had a particularly long path and filename to the image I was
    using and this was being truncated. (as verified by the process list)

    I then looked at the input box selecting the filename by using the slider and
    this correctly shows the truncation that was occuring. I moved my "still"
    around so that its pathname was shorter and the clip was generated

    Maybe a bit of error checking needed or a longer buffer?


  • Salsaman

    Salsaman - 2012-07-18

    Frank, many thanks for your investigation. After reading your comment, I
    noticed there was indeed a limit of 80 characters for filenames in the input
    fields in plugins - this was originally done for aesthetic reasons. I have
    changed the code in svn so that the field length (data) for filename inputs
    will now be much longer, whilst keeping the same display width. This should
    avoid such truncation in future when selecting files using the file selector


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks