No Videos Work, Please Help

2012-04-08
2012-09-15
  • Julia Renning

    Julia Renning - 2012-04-08

    Hi,

    I successfully compiled 1.6.0, and it looks like everything should work. But
    attempting to open any video gives me:

    This does not appear to be a valid video or image file

    LiVES was unable to open it.

    The terminal output just says "Playback speed not found or invalid ! Using
    default fps of 25.000 fps." And later that it failed.

    If I open Lives in a terminal and run it I get:


    * Your system is too SLOW to play this!
    *******

    But I know that's not true, because it runs Kdenlive, OpenShot, and every
    other program with no difficulties.

    It doesn't matter what filetype I try to open, I get the same errors.

    From this thread, I tried this:

    LANGUAGE=en LANG=en /usr/bin/mplayer -quiet -osdlevel 0 -vo png:z=0:alpha
    -noframedrop -ao sdl -channels 2 -mc 0
    '/mnt/sda4/vids/Syrian_Snake_Eaters_and_Puppy_Stranglers.mp4'

    And it filled the folder with png files before saying:

    Playing /mnt/sda4/vids/Syrian_Snake_Eaters_and_Puppy_Stranglers.mp4.

    libavformat file format detected.

    stream 0: video (h264), -vid 0

    stream 1: audio (aac), -aid 0, -alang und

    VIDEO: 512x384 24bpp 29.970 fps 363.4 kbps (44.4 kbyte/s)

    Clip info:

    major_brand: isom

    minor_version: 512

    compatible_brands: isomiso2avc1mp41

    creation_time: 1970-01-01 00:00:00

    encoder: Lavf52.92.0

    Load subtitles in /mnt/sda4/vids/

    ==========================================================================

    Opening video decoder: FFmpeg's libavcodec codec family

    Selected video codec: vfm: ffmpeg (FFmpeg H.264)

    ==========================================================================

    ==========================================================================

    Opening audio decoder: FFmpeg/libavcodec audio decoders

    AUDIO: 44100 Hz, 1 ch, s16le, 48.0 kbit/6.80% (ratio: 5997->88200)

    Selected audio codec: afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))

    ==========================================================================

    No such audio driver 'sdl'

    Could not open/initialize audio device -> no sound.

    Audio: no sound

    Starting playback...

    Unsupported PixelFormat 61

    Unsupported PixelFormat 53

    Could not find matching colorspace - retrying with -vf scale...

    Opening video filter:

    Movie-Aspect is undefined - no prescaling applied.

    using unscaled yuv420p -> bgra special converter

    VO: 512x384 => 512x384 BGRA

    Warning: compression level set to 0, compression disabled!

    Info: Use -vo png:z=<n> to set compression level from 0 to 9.

    Info: (0 = no compression, 1 = fastest, lowest - 9 best, slowest compression)

    png: . - Output directory already exists and is writable.

    Exiting... (End of file)

    Play a file with Mplayer, works like a top. No problems. If I click
    "Troubleshoot" under the Help button, it says everything is there and working.

    Any ideas on what it could be?

     
  • Salsaman

    Salsaman - 2012-04-09

    Hi,

    can you try with the latest version (1.6.1) and see if the problem is still
    occuring.

     
  • Julia Renning

    Julia Renning - 2012-04-09

    I just tried, but compiling gives this error:

    callbacks.c: In function 'on_record_perf_activate':

    callbacks.c:3810:31: warning: dereferencing 'void *' pointer

    callbacks.c:3810:31: error: request for member 'audio_ticks' in something not
    a structure or union

    callbacks.c: In function 'on_fs_preview_clicked':

    callbacks.c:6055:6: warning: format '%llu' expects type 'long long unsigned
    int', but argument 3 has type 'long unsigned int'

    callbacks.c:6060:6: warning: format '%llu' expects type 'long long unsigned
    int', but argument 3 has type 'long unsigned int'

    make: *** Error 1

    make: Leaving directory `/tmp/SBo/LiVES-1.6.1/src'

    make: *** Error 1

     
  • Julia Renning

    Julia Renning - 2012-04-09

    Thanks.

    It compiled now. But it's still the same problem as before with 1.6.0.

     
  • Salsaman

    Salsaman - 2012-04-09

    No idea then. I'm sorry.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks