I have an AST Logitech IR remote working on Serial port that I had managed to make work on a computer in 2007. Now this computer is dead and I'm trying to reinstall everything on another computer without success.

Here is the Hardware:
AST Logitech remote
Biostar P4M80-M4 mother board
     BIOS is set correctly and COM1 is enabled on 0x03F8

The Software:
Mandriva Linux
lirc 0.8.6
no dkms-lirc module as the kernel already support it by default

Here is the thread I had in 2007 when I solved my problem with LIRC on my old computer:

When I apply the same config it's not working, when I run
mode2 --device /dev/ttyS0
it says :
mode2: could not get hardware features
mode2: this device driver does not support the LIRC ioctl interface
mode2: major number of /dev/ttyS0 is 4
mode2: LIRC major number is 61
mode2: check if /dev/ttyS0 is a LIRC device

and when I set /etc/sysconfig/lircd to use /dev/lirc/0,  I get no complains but nothing shows up when I press the remote buttons.
Same thing with irw, when I start it, it returns to the prompt and nothing is shown when I press the remote's buttons.

Here are my actual configs:

DRIVER_OPTS="irq=4 io=0x3f8"

(copied the logitech lircd.conf)

(copied the logitech lircmd.conf)

thanks for helping!

Louis-Martin Carrière