Hi All,
    I'm having a little trouble setting up the winbond-cir driver on my gentoo64 machine and was wondering if anyone could shed some light on what I might be doing wrong here.

Winbond CIR 00:04: disabled
Winbond CIR: probe of 00:04 failed with error -22

(although the module stays loaded, it is not found by lsinput)

2.6.38-gentoo-r3 amd64

Intel DG45FC

For the past year or so I've been using a homebrew IR via serial port and lirc_serial.  I currently picked up a CIR receiver so I want to switch to use it instead.  I looked up -22 as EINVAL code and have been looking through the source code, but I can't figure out what is invalid.  I tried adding 8250.nr_uarts=1 to my kernel params, but that didn't help.  I tried unloading all lirc_serial modules as well, and that doesn't seem to help.  I know there is something funny with how CIR is seen as a serial port, should I disable my real serial port altogether from the kernel?  If there is any other info I can post please let me know.

Thanks for any help,