Oops, just seen there was already a recent mail about this from Willem Jansen titled: Bug with long (<8191µsec) header pulses
Looks like there is a fix too so will give that a go..


On Mon, Jan 27, 2014 at 11:25 AM, Paul Gration <pmgration@gmail.com> wrote:
I've recorded an infrared remote for a Lilliput screen using irrecord with FTDI based hardware.
The remote configuration looks like this:


begin remote

  name  Lilliput
  bits           16
  flags SPACE_ENC|CONST_LENGTH
  eps            30
  aeps          100

  header       8989  4438
  one           596  1639
  zero          596   521
  ptrail        594
  repeat       8987  2201
  pre_data_bits   16
  pre_data       0x4FB
  gap          107393
  toggle_bit_mask 0x0

      begin codes
          KEY_MUTE                 0x9867
          KEY_POWER                0x906F
          KEY_UP                   0xF807
          KEY_RIGHT                0xA857
          KEY_DOWN                 0x6897
          KEY_LEFT                 0xD827
          KEY_MENU                 0x8877
          KEY_SOURCE               0xE817
      end codes

end remote


The header pulse is approximately twice as long as the header space, however when I transmit any of the codes (again using FTDI hardware) the header pulse is significantly shortened - http://postimg.org/image/uq70mdjnb/

The image shows the first 5 transmissions using irsend based on the recorded configuration file, and the 5 subsequent signals are from the real remote.

I have tried adjusting the value of the header pulse downwards and retesting until reaching a figure that looked as it should do. This number was 8191, anything below that appears correctly in the signal with xmode2, if I put that number 1 higher (8192) the signal gets shortened, almost like the pulse value is overflowing at 8192 and being reset.

At 8191 it seems to be close enough for the Lilliput screen to respond to it so it is in fact working for now, but does anyone have any ideas about this issue?

I haven't tried any other hardware, simply because I don't have any other than FTDI devices, so I'm not sure if this is an FTDI related issue or affects other hardware too..

Thanks,

Paul