On 13 April 2011 15:21, Jarod Wilson <jarod@wilsonet.com> wrote:
On Apr 13, 2011, at 6:51 AM, Andrew Bowman wrote:

> On 10 April 2011 19:02, Andrew Bowman <andbow@gmail.com> wrote:
...
> Yippee !  50% there,  now get an output from IRW which I am very happy with.  However I am unsure if the blaster is working yet. There are no transmitter devices in the harwdware.conf

hardware.conf is a debianism, not an upstream lirc thing. The
separate TRANSMITTER crud is a relic from the days of needing
two separate pieces of hardware and two separate drivers and
lircd instances in order to transmit. The mceusb is a single
device, capable of handling both, so that stuff is just plain
misleading and confusing. I'd advise removing anything and
everything under TRANSMITTER there, and only set up the other
section.


> #Chosen IR Transmitter
> TRANSMITTER="Microsoft Windows Media Center V2 (usb) : Direct TV Receiver"
> TRANSMITTER_MODULES="lirc_dev mceusb"
> TRANSMITTER_DRIVER=""
> TRANSMITTER_DEVICE=""
> TRANSMITTER_SOCKET=""
> TRANSMITTER_LIRCD_CONF="directtv/general.conf"
> TRANSMITTER_LIRCD_ARGS="
>
> When I try  IRSEND
>
> andrew@DVRBOX:~$ irsend SEND_ONCE directtv 101
> irsend: command failed: SEND_ONCE directtv 101
> irsend: hardware does not support sending
> andrew@DVRBOX:~$

Not quite sure what's going on there, but I mostly blame it on
the obtuseness of hardware.conf at this point.


> Some more info
>
> andrew@DVRBOX:~$ irsend LIST directtv ""
> irsend: 0000000000000001 1
> irsend: 0000000000000002 2
> irsend: 0000000000000003 3
> irsend: 0000000000000004 4
> irsend: 0000000000000005 5
> irsend: 0000000000000006 6

Those don't look like valid IR scancodes to me.

http://lirc.sourceforge.net/remotes/directv/


> I can on guess that there is still some PEBKAC error in my config.
>
> Andrew
>
>
> This is so frustrating, I have googled till my fingers bled but still I am not sure of a solution. I just don't know how I would configure a device for blasting

It should be dead-simple for mceusb devices, but hardware.conf makes what
should be perfectly straight-forward incredibly obtuse. Would be really
nice if the debian/ubuntu/whoever lirc package maintainers would do
something about it, because its bit quite a few users now.


--
Jarod Wilson
jarod@wilsonet.com


 
 
No luck ... I have tried commenting out and then removing all under TRANSMITTER , still get the irsend: hardware does not support sending message.  The IR Scancodes are OK (I think) copied them from my old mythbox, I have a non std STB.
Andrew