Hi All,

Firstly I want to give my appreciation of what you guys are doing.  You should have seen the smile on my face the first time I booted a distro and the remote worked out of the box! And worked really well!

but alas I have a power-on issue.  that is it - and I cannot find a fix for it.

I have honestly waited a few months before getting to this point.  I have tried many different distro's (mainly live cd's as I don't want to ruin the wife's approval factor!)  I have tried fedora 14 live, ubuntu 10.10 live, xbmcfreak-10.10 builds and the awesome superfast booting openelec.tv build.

I have recently tried (and failed miserably) getting back in touch with my friend the old c compiler and taking just the wakeup routines (nvt_enable_wake etc) from Jarrods code into a little tool that was to set the wakeup registers.  I was promptly told by my mate cc that I'm only allowed to mess about in user space, and kernel space is not something for me.  I did this as a bit of trial and error to work out if something was not allowing these registers to be set.

I have also tried heaps of different solutions like echo USBx> /proc/acpi/wakeup, echo CIR> /proc/acpi/wakeu, crawled through this list looking for asrock/nuvoton/power etc. posted on forums etc.

One strange thing is that I have only found 2 other people with this problem.  I am putting this down to everyone sticking to older or official xbmc builds with asrock drivers. 

I really hope I've missed something super simple!  If I have feel free to hurl abuse!